Alexa can't find NodeMCU

Hi All, I’m trying to setup Alexa with WLED version 0.10.0 on my NodeMCU using an Alexa Fire TV Cube but the app is unable to find the devices. I’ve seen from other sources that it can take some time for Alexa to discover the device but I’m wondering just how long that usually is?

Here are things I’ve tried/configured :

  • Enabled “Emulate Alexa Device” and set Invocation name to something simple, ‘Wall’
  • Enabled ‘Send Alexa notifications’
  • Disabled Wifi Sleep
  • Rebooted WLED after making above changes
  • Confirmed Alexa and WLED are on the same network and subnet
  • Enabled UPnP on router
  • Tried discovering devices multiple times on Alexa app

Any thoughts and suggestions wold be appreciated, thanks!

Hi and welcome!

Unfortunately the consensus right now is that the local Alexa control only works with the following devices

  • Echo 1st, 2nd, 3rd gen
  • Echo Dot 2nd, 3rd gen
  • Echo Plus
  • Echo Show and Spot (unconfirmed)

The unit in the Fire TV cube doesn’t seem to have support for the Philips hue local API WLED uses, which is a shame. I hope that I will at one day have the infrastructure neccessary to make an Alexa skill compatible with all devices!

1 Like

I believe to add to aircoikies response. You only need one of these devices somewhere in your network. Once things are discovered I believe the firetv may work to control an established device.

Note this is from
Some reading I have done in the past.


That is correct, forgot to mention!
As long as there is a compatible device online control will work from all devices (including the app, even when not on the same network)


Hi everyone, thanks for all the quick responses! Just had another question, so could I just get a compatible Alexa device on my network, connect it to my NodeMCU, and take the Alexa device off the network once NodeMCU is registered?

Unfortunately not, the discovering device is the one voice commands will be relayed through, Alexa will say that the WLED device is offline if the Alexa device is unavailable.