Alexa not connecting

New to WLED. Running a nodemcu with 10.2 wled. Works great but alexa cannot find the device. The echo is an echo plus.
Any known fixes?
I did not see a different binary than WLED_0.x.x_ESP8266.bin that would be for the nodemcu with alexa enabled

Did you search this discourse group and review the WLED wiki for Alexa?
It usually relates to finding the right name field that Alexa can use, and enabling Alexa.
Sometimes it relates to the home network configuration.
Sometimes it relates to the wrong firmware is loaded (one with Alexa disabled for example will never work).

Yes I searched it and tried several changes and reboots. Haven’t tried a different release. How can I determine which firmware has Alexa disabled?

The problem was an old Echo Plus unit. I plugged in a newer echo dot and it worked right away.

1 Like

That’s a new solution for me! I didn’t even realize there was a thing called an Echo Plus.

I had same problem and pulling a plug on Alexa and restarting worked for me.