Cannot Connect to WiFi

I’m not able to connect any of six nodeMCU’s with WLED version 11 installed to my WiFi network. I’ve checked the “disable WiFi sleep” button (which has worked in the past). I have two networks and cannot connect to either. The wifi signal is strong and in one case in the same room. Any suggestions would be greatly appreciated. I used NodeMCU-Py flasher to install WLED

Couple questions/things to check.

  • What kind of microcontroller are you using? ESP8266? ESP32? Which bin file (filename) did you flash onto your microcontroller?
  • Does your WiFi password have any special characters in it?
  • Are you sure your trying to connect to 2.4 GHz (vs. 5 GHz) AP?

I’s using an ESP8266. File was WLED_0.11_ESP8266.bin. Passwords contain only letters and numbers. I’ve also tried both 2.4 and 5 GHz but majority has been 2.4. I’ve had success in the past (after several attempts) with three of the boards but after loading WLED 11 I cannot connect.

OK. FYI, ESP8266 only supports 2.4 GHz.

  • How far away from the WiFi Access Point is the nodMCU when you’re trying to connect? Did you try to move it closer to the AP?
  • When you flashed with NodeMCU-Py Flasher, was there an option to erase the nodeMCU before flashing? If yes, did you check that option?
  • What kind of AP are you using?

I’ve been in the same room as my router (Belkin). Yes, the option to erase the nodeMCU was checked. I’m assuming AP means my WiFi router?

AP means (WiFi) Access Point. If you have a “WiFi Router” it combines a router, a WiFi Access Point, and likely a switch into one box. Some people have separate equipment for those (e.g., I have three Unifi AP’s and a pfSense firewall/router).
So, with v0.10.2 you could get the nodeMCUs connected, but after you upgraded/flashed them all none of them connected? Are you trying to connect on a Guest Network? Sometimes Guest Networks won’t let devices on the same network talk to one another. If that were the case, you would be entering your WiFi credentials while WLED is in AP mode. After you hit save and connect, it would attach to the network, but you wouldn’t be able to access the web page if client isolation was enabled. Did you check your router’s DHCP leases to see if your router’s DHCP server assigned the nodeMCUs an IP address?

P.S., If you are trying to use the mobile app, you need to be on the same network as you tried to get the nodeMCU’s to attach to. If not, you won’t be able to “discover” them.

I’m not using the guest network. At this point I’m only using my computer to try to connect using the WLEP-AP. Once I enter my wifi name and password and then hit “save and connect” the WLED AP comes back (most of the time) and under the wifi setup, it shows no connection IP connection. I’ve tried static IP too, but nothing

This may be silly (and not meant to be offensive in any way), but did you double-check your SSID and WiFi password and verify they are correct? No Caps Lock on, etc.? (I’m running out of ideas. :wink:)

P. S., When you say the WLED AP comes back “most of the time”, does that mean when it doesn’t, are you sure it’s not connected to your WiFi?

P.P.S., After you hit save and connect, are you selecting the same WiFi network for your laptop/desktop after disconnecting from the WLED AP? If it autoconnects, your laptop/desktop may be connecting to the other network you have (you said you had two).

Yes, I’ve double checked SSID and password, because I’ve been know to mistype in the past. And after the WLED AP doesn’t surface I check my routers “connected devices” list and nothing shows up.
My laptop is connected to same network that I’m trying to get the nodeMCU connected to. My past successes were not first-time connections, and I’ve tried connecting at my daughters house with the same dismal success. I’ll keep trying, and thanks for your comments.

Sure, no problem. Are the nodeMCU’s from the same “batch”, or purchased at different times?

Sorry, I truly am out of ideas/suggestions. If you haven’t already, you may want to pose the same issue/help request in the WLED Discord.

I have solved my problem by typing in the SSID and password, rather than using “autofill” values from the browser memory.

Interesting! I wonder if your browser’s auto-fill included spaces, or incorrect capiTaLizAtIOn.

I am currently having trouble connecting with a new device. My old phone was connected, but now I don’t have the password to the wifi anymore and am wondering what to do.