ESP8266 NodeMCU ESP-12E Not connecting to Wifi after Flash

Hi All. I’m super new here (and to Wled :slight_smile: ) But I’m having an issue I just can NOT Figure out, and hoping I can get some assistance.

I have 3 ESP8266 NodeMCU ESP-12E modules.
I’m running ESPHome-Flasher-1.3.0 (I’ve tried both 64bit and X86)
I have successfully Flashed WLED_0.10.0_ESP8266 as well as WLED_0.10.2_ESP8266

At this point, I can successfully change over to the WLAD-AP Wireless, connect to and configure my Wifi settings, save and connect.
This is where everything just goes wrong.
I’ve tried using DHCP, I’ve tried assigning a static IP Address.
I have completely the ESP8266’s URL
And I have tried configuring it got 2 different 2gh SSIDs and 1 5gh SSID.

I go look in my router, and I never see a connected device, but logs show that 2 device MACs have connected with the name “WLED-WLED” but I never SEE them connected either.

I’m pulling my hair out (What’s left of it anyways) and hope someone has some words of wisdom :slight_smile:

Thank you for taking time to read my issue, I can’t wait to get past this and start configuring my lights :slight_smile:


It’s definitely something going on with your router. Try to connect with mobile app. App have ability to search network for connected WLED controllers. Use DHCP for sorting out first. Make sure you using proper bin file.

Thank you!!!
That did the trick, still have no idea why I can’t see them on the router, but don’t really care. Once the Mobile App saw them and I had the initial IPs, everything went as smooth as silk.

Thank you again for the tip!!

@srg74 too, care to elaborate? Having same issue as @MrKryton . I had a NodeMCU that worked fine but burned it on accident, replaced it with a new one and can only access it when its freshly flashed with defaul wifi, when I update my wifi settings and click save and connect, I cant connect to it anymore.

my first NodeMCU had no isues.

I’ve tried launching the freshly flashed board with the app on the default wifi but it immediately opens the browser to change wifi settings.

How did you flash your board? Which bin file or build did you use?


jt appears the issue was with my ATT Fiber modem/router, i added an Eero Router to my network and it worked perfectly fine.

Instead of v0.12 use latest beta