Wemos NodeMCU V3 ESP8266 CH340G support

I cannot connect to the WLED-AP with this chip. Is it supported? It does not have a larger WIFI chip like other models.

I take it that you were able to successfully get it to flash firmware? If you connect the esp8266 to platformio/VS Code and boot, what kind of debug data is showing up in the terminal? I’m assuming you used PlatformIO and VS Code to compile / load WLED to the device. If that is not a valid assumption, it would be a good idea to see what kind of debug data is being sent.

I used esphome-flasher according to the following instructions: https://drzzs.com/beginners-guide-to-all-holiday-leds/

When I connect it to a ws2815, 30 leds lit up in orange. So that seemed to work at least.

Tried version 0.10.2 and 0.10.0. I cannot connect to WLED-AP with either laptop or phone: “Unable to connect to this network”

If I write the password incorrectly I directly get an error.

The flasher you are using does it have an erase all option?

Have you tried selecting it? If not try, I have had eeprom settings clog things up.

If it doesn’t have an erase all function let me know I think I can get the link to the one that does easily.

It says that it erases:

Using 'COM4' as serial port.
Detecting chip type... ESP8266

Chip Info:
 - Chip Family: ESP8266
 - Chip Model: ESP8266EX
 - Chip ID: 0001D749
 - MAC Address: 48:3F:DA:01:D7:49
Uploading stub...
Running stub...
Stub running...
Changing baud rate to 460800
 - Flash Size: 4MB
 - Flash Mode: dout
 - Flash Frequency: 40MHz
Erasing flash (this may take a while)...

Using 'COM4' as serial port.
Writing at 0x00060000... (100 %)Wrote 591712 bytes (407625 compressed) at 0x00000000 in 9.2 seconds (effective 516.7 kbit/s)...
Hash of data verified.

Hard Resetting...
Done! Flashing is complete!

Showing logs:

Try a different esp flasher with hopefully a better erase mechanism. I wonder if the erase portion is only erasing the firmware and leaving the data stored from any prior firmware loaded to that same chip.
The NodeMCU CH340G V3 is really a V2 with different ftdi chip from what I read. The esp8266 is the same.

@advaita try this flasher tool It has an option for fully erase. https://github.com/marcelstoer/nodemcu-pyflasher

For 8266 I use:
dual io / dio mode. There is an info button in the app though.

Actually esphome-flasher is based on that flasher. Which in turn is based on esptool.py, which I have also tried.

Anyway it would be strange if an erasing error would cause this oddly specific AP problem, while otherwise everything seeming ok. My first bet is still that there are problems with the AP with this specific chipset.

I actually got the chip to connect to my wifi by uploading a program that tests this.

So I could next try to compile wled myself with my wifi details manually set.

Ok, I inserted the wifi ssid and pw directly into the code and it still did not work.

After adding some waiting I could, however, get the wifi connection established.

 while (WiFi.status() != WL_CONNECTED) {

However, I still cannot connect with the wled app or through ip and it also disconnects and reconnects periodically.

Did you ever get this resolved?

I bought a load of these boards by mistake :frowning:



I’m in the same boat. Did someone made these to work?

I got two of them a couple of months back and I am never going to buy them again.
Ypu managed to flash? I couldn’t even get my pc to recognize them, no matter the drivers I installed

The cheapest 8266 work fine. Esp32 is something I haven’t tried.

Created an account for this lol… think I should just throw away this little card, but has anyone made it to work?

having the same problem.
tried several wled versions, 0.8.2 is working for me.

Thank You! 0.8.2 is working on this board Модуль беспроводной связи WiFi ESP8266 NodeMCU WeMos на чипе CH340 купить оптом и в розницу в СompactTool с доставкой по Москве и России