D1 can't connect to Wifi (Fritzbox)

i’m running several instances which work nicely - i wanted to add another instance but it can’t connect to my wifi.
It must be my router (Fritzbox) - as i can see the D1 mac address under “unable to connect” in my router UI. so the credentials are correct but the router seems to block it. i’ve already tried different settings (disabling 5ghz wifi, changing the wifi channel to 1/11 and such) - no success.
any ideas how to solve it?

Change the mDNS hostname to something unique. Disable d1 mini’s wifi sleep enable in WLED’s default AP. Disable sync (at least temporarily).