Discovery issues with UniFi UDM-PRO from Ubiquiti

Hi,

I’ve tested WLED in many networks yet finally I have found issue in my company network. We are using UniFi UDM-PRO from Ubiquiti. Android does not discover lamp at all while IOS works only when powered up during discovery. Advanced IP Scanner list all devices in network except for WLED. Tested on few hardwares, works same. Same lamps work perfectly in outside of this network. Any thoughts about that?

Thanks,
Best regards,
Tomasz

Have you searched the WLED “issues” on github, and these discourse posts for “unifi” or “ubiquiti”? I think if you had, you would have a 2nd paragraph asking what changes are required for unifi to recognize wled instances.

I do not know, but I have seen more than a couple posts where people have troubles until then change some default behavior that prevents WLED visibility. I think there might have even been one firmware update and configuration change, though that might have been timing of the post and a recent firmware update.

Hi Im using a UDM pro (firmware 1.9.1) unifi switch, unifi wireless AP’s.

I have no issues with the 4 QuinLED and 2x NodeMCU WLED controllers, I also have around 10 Magic Home RGB devices. I do have a separate VLAN for IOT devices and mostly use static addresses for them all.

Although I cant offer any advice, it is working for me.

best of luck

I work in a fairly large international company. If I were to attempt to connect any IoT device on the company network, they would all fail. It would only be after months of negotiations and new hardware to segregate the IoT device(s) from the internet, other business networks, and performing a wifi interference study would I be allowed to bring that device online.

I imagine there are some network management policies / features configured / enabled that protect corporate networks from rogue IoT hardware from being enabled.

A few things you might look for in the UniFi configuration.

  1. Check the “Clients” list and see if the devices are actually connecting and staying connected to the network.

  2. If they show up in the list, but aren’t currently connected, this may mean that if UniFi is using “Band steering” that it tries to move devices off the 2.4Ghz band to the 5Ghz band, even when the end devices don’t support 5Ghz. The ESP8266 and ESP32 only support 2.4Ghz, according to the specs at Espressif, SEE HERE. I’ve seen this a lot with older wifi printers and other 2.4Ghz only IoT devices.

  3. There is an option which I believe can be toggled at the WLAN or the AP level to allow “legacy device support”. This is mainly for older 802.11b stuff, but it’s worth a look.

  4. Other devices, like Global Cache’s iTach WiFi attached I/O controllers, and WiFi remotes from Elan Home Systems, to name a couple, also require the “minimum data rate control” to be enabled and set for at least 1Mbs to maintain a reliable connection.

Otherwise, like @huggy-d1 said, there might be policies in place to prevent certain devices from connecting to the WLAN, and/or sending certain discovery broadcasts.