ESP Unresponsive after about 12-24 Hours - Home Assistant Connected

I have an ESP32 driving 600 WS2812 LED on a 5V 10A supply. It has worked well for about 6 months with Home Assistant turning it on and off, but recently it becomes unresponsive after 12-24 hours.

The ESP32 hasn’t crashed as I can still get to the web UI, but strangely, even through the web UI pressing the power button does nothing to the LEDs, but it does toggle the power button colour in the web UI. If I select a preset through the web UI, then the LEDs come back on, and it works for another 12-24 hours before becoming unresponsive again.

I have swapped out the ESP32 board with a different one and have also tried both the Release and Dev versions of the WLED software - Same problem in all cases.

Any ideas?

in the Timing config of the WLED you can make a system reset TIMED

or use one of the Pins to trigger the Reset on timing lets say 02:00 in the Morning

Thanks! Your answer may have led me to the problem. I couldn’t find the timed reset, but I did find the schedules.

All of the schedules were enabled and set to select preset 0 at midnight. When I set up the system recently I split the led strip into 2 X 300 led strips and created a preset. But this preset was given the number 1. I then deleted preset 0. So at midnight the strip was set to a non-existent preset 0.

Seems OK today, but I’ll test for a few more days before marking solved.

You shoudent NEVER EVER Delete a Predefined setting on whatever Multiple system if you can choose a Cosrtum one in settings

Most systems as well as WLED use internal BASE settings that are only in the Predefined available and used by the ones that hook up to this