Esp32 crash after a couple of minutes

Just as the title says the esp becomes unresponsive after some time. The web interface stops responding and the leds freeze. trouble shooting wise I have tried:
switched 12v powersupply.
Removing all leds.
Swithed what pin I use for led data.
Using an external 3.3v regulator.
Put a capacitor on the 5v led power or/and the esp32 3.3v power.
Put a 470 ohm resistor between the led and the esp on the data line.

Done all of the above on both a esp32 modemcu devkit v1 and an esp32 WROOM module.

the setup I’m trying to achieve is using a WS2812B led to boost the signal to an WS2815 strip with 594 leds on it. I’m using buck regulators to step down 12v to 5v and 3.3v.

Why are you powering the esp32 with 3.3v and not 5v?

1 Like

I’m powering the esp through the 3.3v input with 3.3v and have tried powering it just through just the usb the same problem presists.

It needs to be powered from the usb or the 5v pin. Not the 3.3v

As I said I have tried both ways, and no the wroom module is not 5v tolerant that would fry it I have powered a nodemcu with 5v and powered a wroom module with 3.3v both tests had the same result. I suspect it has something to do with home Assistant as polling the word device too often.

Ah gotcha. Generally no one is ever using a bare Esp32 chip. I assumed you were referring to either a node mcu or d1 mini style. Does it crash with no LEDs connected?

Yes I snooped the discord and some people reported it was home Assistant. So I restarted HA and its more stable but it still starts crashing after like a day or two and then I need to restart HA again

1 Like

So i have a similar issue:

ESP 32 WROOM Module on an custom board. Power supply over USB-C so 3 amps. 3.3V regulator is a 1117 type. Running 60 SK6812 leds.
It starts crashing from a few seconds to a few minutes. Running the most recent version via the web installer.
If i switch to a nodeMCU it works flawless with the same LED-Module.

Things i tried so far:

-adding more capacitors to smoothen the input power (like 100uF in and out)
-powering the 5V and the 3v3 from my lab supply (grounds connected ofc)
-connecting to a router - improved runtime but still crashed
-tried a different voltage regulator

nothing helped, WLED still freezes. What i noticed is that i still see the wifi and can connect but the web client wont load

I am out of ideas but i am pretty sure i made a design mistake

Hello! I am having the same issues, Esp32 board is crashing after 1-3 minutes powered by usb. I don’t think it is a coincidence.
Any ideas other than to buy new board?

Hard to say w/out more info.

Are you using Home Assistant?
How many Amps is the usb power supply?
How are your LEDs wired?
Does it do it with no LEDs connected?
What version of WLED?
What is the File size on the controller from the GUI info screen?

Yes, but I think no relevance. I took the Esp32 out from Dig Quad and powered from notebook USB. Also, I reinstalled today WLED 0.13.3 and without any LEDs after aprox 1-3 minutes it crashes. I don’t know from where to get file size.

Thank you!

I would reinstall WLED first.

This is the info page:

Same issue! I am using a dig-uno v3. With an ESP32 it was working better and now after 1-3 mins is crashing. tried both 14 beta and 13.3

Same issue here. I can’t get my head around what’s wrong with my setup, after just a few minutes it gets unresponsive.

I have a 5V led strip with 606 leds, approx 380 cm, this is connected to an ESP32 with a 480 ohm resistor on the datacable.

I power the ESP32 on the GND + 5V pins and using pin 4 for the data.

With the brightness factor lowered it managed to live for approx 5 minutes, otherwise it dies after 1-2 minutes. These are the things I have tried so far:

  • Power supply 14A 5V, using limiter to 10A
  • Power supply 30A 5V, using limiter to 20A
  • Power supply 30A 5V, using limiter to 25A
  • Power supply 30A 5V, without limiter
  • Tried two different ESP32 boards
  • Tried wled 0.14.0-b6 and 0.13.3
  • Tried with and without Homeassistant
  • Tried to set the brightness factor to 50% and 30%

Did you get it to work?

I was having constant crashing on all 4 of my ESP8266 setups running multiple versions of 14.x … switching back to 13.3 stable fixed it for me. (so far at least)

Running latest Home Assistant.

Ditch HA or upgrade to ESP32.

I sorted it out, tried another ESP32 and have worked without any crash since then, so the two first I tried had some issues for unknown reason.

1 Like