Firmware ESP32 S3 LOLIN - WLED_0.15.0-b2_ESP32-S3_8MB.bin

Hi guys! Can I ask you for advice on installing ESP32 S3 LOLIN. To see the information on the last video: “NOTE:
This release includes boot loaders for S2, S3 and C3 chips, as well as flash memory partition cards of 4 and 8 million for them. You will need to flash the loaders with offset 0x00000 for C3 and S3 and offset 0x01000 for S2, partition maps with offset 0x08000 when manually flashing using esptool. The firmware is flashed with an offset of 0x10000.” I tried to do everything as described. At first, there were attempts to install the firmware from the site after that, the ESP began to go into a cyclic reboot. Next, I read the note more carefully, and began to perform all the steps step by step. 1. I used S3_bootloader.bin and flashed with offset 0x00000 for C3 and S3 via ESP TOOL. 2. I Took The Firmware WLED_0.15.0-b2_ESP32-S3_8MB.bin
and flashed with offset 0x10000. After the restart, the problem with the cyclic reboot went away, I thought victory was so close.But then a fiasco awaited me. The board does not create a WI-FI hotspot, just nothing happens. I don’t have much experience in this environment, I was looking for a ready-made solution, but no detailed information was found. Please tell me the correct sequence of actions when flashing through the esp tool, maybe I did something wrong. I would be very grateful if someone before me could do everything correctly and describe the sequence of actions. I have S3 V1.0.0 - LOLIN WIFI BLE IOT Board основанная на ESP32-S3-WROOM-1 16MB FLASH 8MB PSRAM

I also have LOLIN S3 V1.0.0 and there is a detailed post on discord for how to flash that exact board

After the initial flashing works for you can OTA latest or other builds , if you have issue accessing the link , go to wled discord and search for post from Softhack

1 Like

Thanks! I did it the first time.

I would like to clarify the last question. Now I have everything connected to WI-FI. I connected one GND wire as indicated above in the picture. And connected the control wire to the 38th leg. I could have made a mistake, so I’m asking for a little advice. In the WLED settings, I specified 38 feet to control.

Apparently I’m doing something wrong after all. I have all 350 diodes lit on the tape. But the control in WLED does not work. For any command to change the color palette, the diodes simply blink, including when the WLED power is turned off. I hope I didn’t make you uncomfortable with such questions.

What strip are you using?

Pin 38 is connected to the LED that is on the board itself. That should light without the strip connected if set up with 1 LED as a test, but then you ptobably want to use another for your strip.

I use WS2812 on 5V, I have 350 LEDs in total. Now S3 Lolin is powered by USB from the OTG port. I most of all doubt the correct choice of the 38th leg, so I ask for advice on the correct connection of the control wire. So that I can manage the tape in WLED

I use gpio16 for 16x16 matrix , i also use gpio38 for the onboard led

I will describe in more detail what is happening to me now, regardless of the settings. When the power supply is turned on, the entire tape lights up and the LEDs flash cyclically in different colors

in a chaotic manner.

As you previously advised, use leg 16. On the board, I connected the control wire to the 16th leg. And went into the WLED settings. To set the GPIO to 16.

Before writing, I tried the other legs on the control board as well. But the bottom line is that the diode tape lives its life and continues to shimmer with its colors, not responding to any commands.
I don’t even know why this is happening. When using other boards, everything seemed easier to set up.

Not really sure of anything beyond the flashing if your wiring is okay or not ( other guys
might be available to help you with that if you show your wiring or draw that ) .
To test in a practical way you can connect a small strip of say 10 leds and power it
directly from your board .

Other than that i could provide you with anything you like from my board ( it is next
to me and running a MM fork which I updated with OTA to test other usermods ) If you need
the bins for MM then it is here

1 Like

Sorry to waste your time. I myself was not happy that the problem was still in the wiring. The other board was working correctly, I decided to connect it back to the same wiring to check the result, and it turned out that it behaves the same way. The problem turned out to be in the wires, which were apparently bent very much, twisting them a little, everything worked. I am so glad that thanks to your advice, I was able to set everything up and achieve the desired result. I hope this topic of discussion will be useful for someone in the future.

Sure brother , glad it worked for you , please keep it up

1 Like

I have a theoretical question for you. Is it possible to update the configuration that was manually stitched to newer versions of WLED - WLED_0.15.0-b2 ? Whether this will become a problem and the reason for re-flashing manually, you described earlier.

Yes possible but ( and it is a big butt ) 15.0-b2 is not in release state yet and full of bugs so i would not use it on esp32s3 . If you have free time to waste on that then might be try it out on normal esp32 first . On the other hand what you got to lose as if you face issues you can roll back to 0.14.3 ( not 14.0-b3) which might be better suited so might be try that version . At the end if you are not facing issues and do not miss a feature then do not rush to update .

1 Like

Thanks! I’ll leave the version that is now. Thanks again for the advice. It was a pleasure to have a conversation with you in this discussion thread.

1 Like

Glad you mentioned this.
I’m not sure what I’m meant to see.
S3 8mb S3 16mb…

Read the same post…
I use moonmodules… So thats the only difference in that process…

Yet fails when I flash using this instructions.
Made simple bat file to execute command prompts…

Psram… No Psram… I don’t know what I’m meant to see… I bought these thinking I’d have more “ram” than before for presets… no low memory warnings… No reboot crashes…

But I’m not getting any part of that yet
Tried a few variations of build for s3… Boot flash… I partition flash… Bin flash… All I get is flash crash lol

Only thing that works is the 4mb bin… bizzare

I do not have other s3 to test but only having lolin s3 listed here

As you can see in the specs it is with 8MB PSRAM (Octal SPI) so that is the file you should
use with that board . Check your board site to be sure but all c3,s2 and s3 might be
a bit tricky depending on which board you have , try wled discord as other may have
the same board if it is not lolin s3 .

Something else you should note that if any bin works for you then just use that as PSRAM will not really improve performance ( it was mentioned that it could be useful for large ledmaps but i never had a chance to test that to verify )