First Pixel = Green then nothing

So I have a question, made an account just to ask.
My strips are ws2812b 5v w/ Dig Uno
Is there some type of “code” the lights are trying to tell me when only the first pixel is illuminating -Green
Had another strip illuminating the green pixel at the very end. Sometimes it will illuminate 5 white then nothing.
What’s this mean?

Check that you’ve got a return signal (-) to the power source. I’ve seen this when my strip is getting a control signal and there’s 5 volts to the + pin but open circuit on the return.

Thank you sir, it was definitely a ground issues.
That’s solved nur LOL Controller, ——> Strip(5m)——> Strip(5m)
Now I cannot get the second strip to illuminate. The first strip is getting fed Voltage from Diguno + Fed at the beginning + middle with a 20amp 5v supply.

I cannot get the second strip to light up. Its fed from a 5v 40amp power supply. Grounds tied together
Data is fed’from the last of the fseeqq

Using a multimeter, confirm 5v at the input of the second strip. If you can, check for 5v at other location on the strip to ensure you’ve got good continuity with your connections. If that checks out, troubleshoot the data line. If the distance between the two strips is long you may need a larger gauge wire to reduce the voltage drop. You may need to redo the connections.

So on the second strip I have it’s power coming from a 40a 300w 5v power supply that’s about 12ft away on 16awg Wire on a distribution fuse block that then branches off into 5 separate circuits for injection w/ 18awg wire. I just can’t seem to get the first strip on the run to light let alone the others down the line.
I have 5v at the strip. I have 5v at my next injection point as well (same power supply).
All common grounds tied together.

Question:
Should the strip at least illuminate even with no data signal or does it need one?
I have a sp901e that I can use for data straight to this strip but haven’t tried it out yet.
The strip in question is a known working strip, it did light up once but the weird thing is, it was lighting up random pixels, and random colors.

Went back and double checked connections at the end of working strip. This strip is on its own power supply, the next strip is then on its own, I’m getting 5v, re soldered working strip data to non working strip data. Still nothing.
Wled is set to 400 pixels.
I’ve spent countless hours trying to make this work :frowning:
It’s 10pm 2 days after Christmas and still on a ladder. This is on gutter outlining the house. I have another diguno that i connected to the non working strip and everything worked so I know it’s good. Could this be a coding issue?

If you don’t have a data signal the LEDs won’t light at all. If you have an intermittent or weak signal you will see flickering, random, or non updating colors. Since power injection sounds like it’s checked out, check the data signal. How long and what gauge wire are you using from the source of the data signal?