Govee Permanent Outdoor Lights - Flashing at high brightness

Hi All,

I’ve got a strange issue with my Govee Permanent outdoor lights, of which I control via WLED - when I set the brightness to anything over 100 on the slider, I get random lights flashing different colors for a second or so - if I set the brightness to anything below 100, then the lights stay static on any color I set them too.

I’ve got an external 10a 36v PSU powering the lights, which is more than enough for the string of 150 lights - as they only require 5a

I’m controlling the lights using an ESP32, hanging off the same external 24v PSU, using a dropdown convertor from 24v to 5v - so I’m sharing the grounds.

I’ve got 2 strings being controlled off the ESP32, one string if 80 and one of 70, and they both exhibit this behavior.

Any ideas where I can start looking into this issue? I’ve tried re-crimping the terminals etc, but random LED’s still change color, or flash. Its also worth noting that at the higher brightness, the transition fades are very much like strobe effects - where-as at lower brightness, these are very smooth.


Try and set a segment with only the last 10 LEDs, everything else dark, and see if they exhibit the same behaviour.

You could try and create a preset with the brightness entered as “254” (or less) to see where the flashing actually starts.

What version of WLED are you running?

No level shifter?

Hi @divsys - yes, I’ll give that a go - but it looks like anything over a brightness level of 100 causes this strange behavior - interestingly, I’ve tested this on a Govee set of string lights, and they exhibit the same behavior when bright - wondering if its a incompatibility thing.

WLED version is the latest release: 0.14.1

ironically I tried this, and it made the problem worse.

I’ve done some more testing today - and it turns out that using any static combination of Red, Green or Blue works fine and doesn’t flash, but as soon as I try any combination of lights - such as ‘white’ or ‘warm white’ - I get the flashing and flickering - putting a multimeter on the end of the run, I’m getting a voltage drop of about 3v when it flickers - so I can only guess that I’ve got a dodgy transformer which is dropping the voltage under load when all of the LED’s are on (a combination of R/G/B)

I’ve ordered a new one which is also higher rated, just incase, and I’ll report back.

Or wires that are too thin. Compare the voltage at the start and end, if it’s correct at the start then the supply isn’t your problem, wires are.

You can try the current limiter function too.

Then you used wrong one or connected it wrong.

Yes, you might be right here, I’ve tested the transformer end and its a solid 36.5v even with them all flashing outside - what confuses me more, is that I’m using the Govee supplied cables - I just cut them off the Govee Controller - and they are boxed with over 200 LED’s - whereas I am only using 120 in total.

Everything appears to be cabled correctly

The only strange thing is that the transformer that is shipped with the lights is rated at both 24 and 36v - when I looked at the cables, I was getting 24v between red and black, and 12v between yellow and black - yet, they are joined before going into the controller - thus giving 36v (I can tone the red output with the red input and yellow input) - so that’s why I opted for a 36v transformer.

Unless anything obvious stands out, I’m stumped.

Do you have logic level shifter installed for the data output from the esp32?

What is the model number of the lights you have as most if not all of the non pro version runs 36 volts.

Hi - the model number is: H705A2D1UK - I’m powering them with a 36v transformer.

I tried a level shifter - it made the problem worse.

They you used the wrong one or didn’t connect it correctly. What did you use?

I would try use the original controller with your PSU and measure the current.
I don’t know those Govee things but I’ve come across several controllers that have a built-in limiter (like you can enable in WLED) and limits total current to the equivalent of maybe one color full power because the wiring etc are not able to actually power every color at full at the same time.

I am using one of these: - one string wired to path 1 and the other string wired to path 4 to keep them totally separate.

Unfortunately, that’s the wrong solution.
Those are the classic I2C levelshifters, well known to have speed and compatibility issues with addressable LEDs.

Look for some of the 74AHCTxxx based devices.
They work with only a 5V supply and have proven to be some of the best solutions.

I had the exact opposite issue, unless my lights were set to 100% power and white I got random colouors and patterns. I checked and double checked everything and was pulling my hair out. The LAST thing I swapped out was the green breakout board the ESP32 was sat in (to make cabling easy). THAT WAS THE PROBLEM!!! I see you have one similar to mine

All the traces looked fine, could not see anything wrong with it at all. BUT, once I tried my setup with out it it worked 100% as expected and the break out board went in the bin!

Hi All,

No luck I am afraid, either with the 74AHCTxxx level shifter, or with removing the breakout board. I can only assume that the lights are not true WS281x LED’s - and may be a slightly different protocol - which is causing this random behavior.


You had the 100nF bypass cap across the '125 power pins?

Hi all - an update to this - I bought a QuinLed controller and that appears to have solved the issue - why this is the case I don’t know - but if it helps anyone - then it might be worth trying one of those.