Help with multi_relay needed


I am fairly new to WLEd and I am struggeling to get the multi_relay usermod on my wemos d1 (esp8266).

I tried to compile it according to using the build flag in my platformio.ini . I can compile without errors but after uploading the compiled firmware it is not working at all (no connection to board and using the web installer there is only the option to install new).

After that I tried to find a ready to use bin file from @srg74 Github repository but I didn’t found ony for esp8266 with multi_relay. I tried this one but it doesn’t seem to include multi relay. At least I cannot find anything on the wled config usermods page.

Can anyone point me to a suitable bin file or help with the compilation?

THX in advance, Kai

Follow the instruction found here to compile on gh or vsc WLED Compile helper ( , just make sure to check multirelay box


If for some reason you can not or it does not work then reply and i will create a bin and post it on gh , i do not have a board with relays to test though

Hi Adiy,

I tried with your instructions but the compilation failed with this error:

Compiling .pio\build\custom_build\src\wled00.ino.cpp.o
Linking .pio\build\custom_build\firmware.elf
c:/users/lab/.platformio/packages/toolchain-xtensa/bin/../lib/gcc/xtensa-lx106-elf/10.3.0/../../../../xtensa-lx106-elf/bin/ld.exe: .pio\build\custom_build\firmware.elf section `.text1' will not fit in region `iram1_0_seg'
collect2.exe: error: ld returned 1 exit status
*** [.pio\build\custom_build\firmware.elf] Error 1

Would be nice if you can supply me with an ideo how to resolve thi or just a bin file!

Thanks for your help. Kai

Unfortunately compiling multi-relay for esp8266 on gh also fails for me and i do not have access to local vsc to tinker further at the moment , Might be wait a bit for others to help . @srg74 or @wladi_wled could tell as this is above my pay grade

I just compiled with Multirelay ok.

Creating BIN file ".pio\build\custom_build_Multirelay\firmware.bin" using "C:\Users\KJen\.platformio\packages\framework-arduinoespressif8266\bootloaders\eboot\eboot.elf" and ".pio\build\custom_build_Multirelay\firmware.elf"
bin_rename_copy([".pio\build\custom_build_Multirelay\firmware.bin"], [".pio\build\custom_build_Multirelay\firmware.elf"])
bin_gzip([".pio\build\custom_build_Multirelay\firmware.bin"], [".pio\build\custom_build_Multirelay\firmware.elf"])
================================================================ [SUCCESS] Took 209.34 seconds ================================================================

Environment              Status    Duration
-----------------------  --------  ------------
custom_build_Multirelay  SUCCESS   00:03:29.341

custom_build_Multirelay.bin (855.8 KB)

Compiled with this option:

extends = env:d1_mini
build_flags = ${env:d1_mini.build_flags} -D USERMOD_MULTI_RELAY
1 Like

That is great , strange thing i just did the same environment on gh and it fails

Can you also verify you could compile on gh using this as a guide so we could report it
WLED Compile helper (

Ok I tried and failed as well compiling on Github, same error.

Hi akris,

I installed you bin and it worked flawlessly!
The setup I imagined also works. I now can use the relay method to play a sound file whe a certain preset is used.

I will try the Github method just to know if it works for me.

But huge thanks for your help!


Github compile will not work for esp8266 but will work just fine for esp32 , , i think akriss has an updated libraries on his vsc so you need to also make sure you vsc is updated .

1 Like

I thought my VSC was up to date but I will check again …

Use -D PIO_FRAMEWORK_ARDUINO_MMU_CACHE16_IRAM48 in your build flags for ESP8266

I don’t know what the hell plaformio did. But today It is not compile. no changes made to any files nor setting. It just throws the same error as compiling on github.

platformio is a strange schizophrenic beast.

edit:Also tried the github compile, and it’s still failing, but Adding

Works. However the firmware well not work after a fresh flash. I can’t access the module after setting wifi

Me too.

Hello, Even I am facing same issue when I am compiling a custom usermod for we mos d1 mini board.
Usermod used: usermod_v2_rotary_encoder_ui
Board: d1 mini.
c:/users/rudra/.platformio/packages/toolchain-xtensa/bin/…/lib/gcc/xtensa-lx106-elf/10.3.0/…/…/…/…/xtensa-lx106-elf/bin/ld.exe: .pio\build\d1_mini\firmware.elf section .text1' will not fit in region iram1_0_seg’
collect2.exe: error: ld returned 1 exit status
*** [.pio\build\d1_mini\firmware.elf] Error 1
=============================================================== [FAILED] Took 27.73 seconds ===============================================================
Environment Status Duration

d1_mini FAILED 00:00:27.731
========================================================== 1 failed, 0 succeeded in 00:00:27.731 ==========================================================

  • The terminal process “C:\Users\rudra.platformio\penv\Scripts\platformio.exe ‘run’” terminated with exit code: 1.
  • Terminal will be reused by tasks, press any key to close it.

I tried using this flag -D PIO_FRAMEWORK_ARDUINO_MMU_CACHE16_IRAM48
after this the code compiled but wled was not working even wifi AP was not showing up.

Can anyone help me with this one also?