IR remote stopped working after update

Hi All

Can any one help me here please.
I had 0.12 runing with IR working fine. I have updated to 0.13.1 and it stopped working.

I have changed settings to json and downloaded file from IR page but still no joy.

Can any one tell me if i missing aomething here.

Thanks in advance


Did you check which pin is used for IR?

Hi Thanks for your time.

I got pin same 21 as it was before it worked.

I have tested remote and remote producing correct hex codes but wled not having it.

I tested json 24 and 44 controllers no joy both not working.

There’s a general method of debugging IR Remotes in the KB: IR Remotes

Essentially you watch the serial port after you’ve configured WLED’s IR GPIO and press buttons on your keypad. You should see various codes appear corresponding to the IR keys you press. These are what gets decoded by WLED to perform various functions.

Step 1 will be to make sure WLED is reading anything at all from your IR remote.
Then you can try and make sure it does something useful with that code.

Thanks for your time.

Wled dont report enything over serial.

I have to flash my spare board with IR-Remote code to get readings.

Ir-remote reports matching readings to Jason files so remote working.

When i connect to wled and serial i get nothing on button presses. And im testing same pin on IR-remote.

Thanks again