JSON error 9

Hi there!

I have been playing with WLED for a while and decided to implement the staircase mod. I had this working well on my ESP8266 and yesterday swapped over onto an ESP32. I had a lot of trouble flashing and getting to compile but then google saved me with holding down the boot button… Sigh. Anyway, WLED is up and on the network. I can access via phone and my PC but for some reason I cannot send JSON commands from GIT CMD which i was using with no issues on the ESP8266. I’m getting this error which no amount of searching on the forum or google pulls up any info:

C:\Users\markd>curl -X POST -H “Content-Type: application/json” -d ‘{“staircase”:{“enabled”:true}}’ x.x.x.x/json/state

I can go to the IP address (i removed it in above) and get the json status that it is enabled etc. Any ideas? I use the command to test each strip i add as i go with the build.

Cheers in advance!

Retrieve a full json configuration of your ESP32 WLED system so you can see the proper json. If the entire configuration returned via json does not show the staircase object, that usermod is not being enabled on the esp32 build.

Hey Huggy, thank you for replying! Sorry for the delay. Shortly after the above the board stopped connecting to wifi and then after that booting entirely and i’ve not been able to reset via normal means (Cap between GND and EN). I think the board overall has flaky and now dead as a dodo. I reflashed a 8266 and it connected to wifi and i got the same error from json again! I noticed something in the code i was using was different for checking status (maybe since i’m on Windows). I removed the ’ ’ in the usermod provided code (marked in bold): C:\Users\markd>curl -X POST -H “Content-Type: application/json” -d {“staircase”:{“enabled”:true}} x.x.x.x/json/state

Worked immediately! Still shame i can’t now use the ESP32 to go back to… I have 900 5v LEDs with 10 segments, am i right in understanding the ESP8266 is going to struggle with this? I have a 5v 60A power supply for the LEDs themselves and powering ESP via USB. I will get a replacement ESP32 anyway