Staircase light Tutorial and Blank Screen Error for WIFI Settings


I am completely new to the topic of WLED and have a few questions that I have not yet been solved or are still unclear to me.

LED: ws2812b
Controller: ESP8266
WLED Version: 0.11.1

WIFI Settings Blank Screen:
After the initial setup and the assignment of a static IP I can access the web interface without problems and control the LEDs. I also get into every submenu. But as soon as I want to enter the WIFI Settings menu, I get a blank page in every browser. Why this is so I can not say. Are there any solutions for this?

Question of understanding or solution for a project:
I would like to realize a staircase lighting.
I had thought to divide each step into segments (LED 1-40 = Segment 1 / LED 41-82 = Segment 2 etc.). These segments I would then gradually controlled via my home automation Loxone via http command.
How do I achieve a staircase lighting such as here in this video?

or like here

Evtl you have a tutorial here for me how I realize the staircase lighting, because I do not know at the moment.

Thanks a lot

1 Like

Ok the problem with the blank screen in wlan settings are solved.

My ssid containt a space and a point (.) .
This is a bug. With a point and a space it does not work good.

Hello Maveric, the staircase in the video is a friend of mine. He first did this with a combination of WLED and Home Assistant, but that was not optimal. We created a usermod for WLED, you can find that here (it has instructions on how to get things running):

Please note that this is on a branch, once everything is the way we want it I’ll create a pull request and hopefully it will be part of a next version of WLED so we can all have cool stairs like this :slight_smile:

1 Like

Thank you :slight_smile: i will look into it. I also want to combinate my WLED with my Homeautomation called “Loxone” and want to trigger it with an udp command. Im new to WLED and have to look how to integrate usermods.

But Thank you for the info :smiley:

is it also posible to trigger the PIR pin via an http or udp command? That i dont have to use an PIR connected to the board?

I have a straight staircase how do you do the wiring so that it’s nicely hidden? Do you have to tear a bunch of stuff apart or is there an easier method?

Also is there a way to use like a laser break or something other than pir? I currently have this setup going.

It works okay but the pir sensors can be finicky or difficult to get it working properly. It works most of the time though. I would much rather do the lights under the lip of each step.

At the moment the usermod can not do that, because his problem was exactly opposite; It should work even without network (when power was lost and the network doesn’t come back up, the stairs still need to light up).

But with the current implementation of PIR Staircase, it would not be that hard to expose the PIR states in the json and also make them “writeable”. That would enable you to simulate a PIR trigger at the top or bottom. I’ll see if I can add that, thanks for the tip, I’ll let you know when that works so you can use it.

1 Like

it would be nice! in this case you can decide if you want a hard wired PIR or a PIR who triggers a UDP command from a homeautomation .

I’ve added the API commands, but didn’t test them yet. You might want to give it a try.

Note that the name “PIR Staircase” may not be very fitting anymore, this might change before I make a pull request to WLED.

1 Like

nice :slight_smile: i will give it a try. My new staircase will be installed in like 1.5 month. Then i can test it :slight_smile:

And? Happy?

Please note that the usermod is renamed to “Animated Staircase” and is now submitted to WLED as a Pull Request: Animated Staircase Usermod by realrolfje · Pull Request #1763 · Aircoookie/WLED · GitHub

1 Like

Hi There :slight_smile: i can test it in like 1 Month. We are getting a new staircase installed in our new building. As soon as this is ready I try out the project

quick question. If I have defined segments and deactivate the usermod via the API (i.e. deactivate the stair light) and select an effect, this is assigned to a segment. Or is the effect then active on all segments? I’m here about a change of the staircase light to normal mode and back :slight_smile:

Hi Maveric, the usermod respects the setting of each segment and will not change it. To change effects on segments, you disable the plugin (as you did), then select a segment (put a checkmark in the top left of one or more segments in the segment settings page), and then select the effect that that segment (or segments) need to have.

In short: Disable plugin → Enable segment → select effect.

The Animated Staircase will not change or copy the effects of the segments. I hope this helps.

(by the way, the usermod just got merged into the dev branch of WLED)

Hey Rolfje :slight_smile:

I have finally managed to finish wiring the stairs and connect them.

But now I am facing a small problem.

I can enable the staircase mode with the API command


and with


This works without problems and is also displayed in the info.

I noticed an error in the readme.

Here it says that


would be for the topsensor. According to /json/state retrieval, however, it must be “top-sensor” :slight_smile:

likewise for the bottom sensor. Again, the hyphen is missing.

So I triggered the API command {“staircase”:{“top-sensor”:true}} and only the first level starts to light up for about 15 seconds and then goes out again. Unfortunately, the stages do not run. Do you have a solution for me?

After the reboot of the controler it seems that the function is changed. Now the first 2 steps work.

Bottom Sensor triggers API comand. Step 1 goes on after 150ms step 2 goes on. After the duration step 2 goes off first then step 1. But the other steps dont want to turn on :slight_smile:

If i deaktivate the usermod i can controll all segments with no problem. so the wiring is and the controler is ok :slight_smile:

Hi Maverick,

Thanks for noticing the hyphen, I’ll fix that in the documentation.

As for the segments not turning on: Maybe the segments are not enabled when turning on the staircase usermod. Can you try the following:

  • Disable the staircase usermod
  • Enable all led segments and turn them on in the settings (your whole stairs should light up)
  • Enable the stairecase usermod

Let me know if this fixes the problem.