Ledmap upload

Hi to all,

Newbie here. I’ve done that ledmap.json file via /edit. How can I upload that to my Wemos Mini?


If you saved the ledmap.json in the /edit page, it is already uploaded to your Wemos.
Just reboot it once and your LED map should be applied :slight_smile:


I am still fighting with this. I have a strip with 40 SK6812 mini (home made). When I’ve done this I put the leds diagonally (in order to have 4 rows of 10 leds each) without realising. Now I have a sequence like 1,2,3,4,5,… and I need one like 1,5,9,13,17,… to form a row.
I tried this:
{“map”:[0,5,9,13,17,21,25,29,33,37,2,6,10,14,16,20,24,28,32,36,3,7,11,15,19,23,27,31,35,39,4,8,12,16,20,24,28,32,36,40]}, but is not working as I want. What should I do to have 4 addressable rows?
Thank you

It looks like whatever I put in the ledmap.json file it is “saved”, but the board never received that new configuration.
There is a safety mechanism to prevent loading of a new map?
Can somebody explain how this feature works (in steps)?


If you hit save on the /edit page, your file will be saved to the board correctly, the problem might be with applying the map somehow.
Can you share a picture of your hardware, so I can see what mapping you’d like to achieve? :slight_smile:

Here you go. I design this board without thinking. Leds should be in line, not diagonally. I try to use led map to solve my stupidity.

Thanks :slight_smile: Cool board by the way! What model are those tiny LEDs?

Your mapping likely doesn’t work correctly because the indices are not 0-indexed (you need to think of LED1 as LED0). This could work (your mapping, but each number is smaller by one):



Leds are SK6812 mini (3535 adafruit). I figured out the right stream.

  • how can I have only one row with a choosed color?
  • how can I see the json file (I presume I can make modification’s there)?


If you want only one row to be lit, set the segment stop to 10.
If you want all the LEDs in the row to have the same color, set the Grouping to 10.

What JSON file do you want to modify? :slight_smile: The light state, configuration or LED map? The latter two you can see in the /edit page

I put stop at 10 and group 10:


and I have 3 leds on the first row (0,4,8) lit up. It looks like is ignoring the map.
Any suggestions ?
Any way to address leds individually or by map/row?


That are the first 3 LEDs of the map, so the mapping is likely working.
I would expect 12,16,20,24,28,32,36 (so, the entire first row) to light up, too. Did WLED drive all 40 LEDs successfully (even though in the wrong order) before you enabled ledmap?

Yes. That was my thiking as well (lit up all row). Yes wled lit up all leds before and after map.

Here are some shots. All named with the process applied (Circus for all patterns). Maybe this will give some clues regarding wht happend.

Still no clue what’s going on, sorry :frowning: What does 40 LEDs, Grouping 1, “Palette” effect with Default palette and speed 0 look like (with your ledmap applied)?

It looks like this.

Any other thoughts?

Thanks :slight_smile: From that it really seems to me as if the map is working correctly. If you use e.g. the Wipe effect, the first row should turn on, then the second, and so forth :thinking:

Correct if I use all 40 leds, but If I put start 0, stop 10, grouping 10, spacing 0 I have 3 led (first ones on the first row) lit.

It looks it is working by the ledmap, only if you use all leds defined in config. If you use less is give you wrong output. Any other advices?