Olimex ESP32-Gateway Ethernet configuration

I have installed WLED 0.15-0-b4 (Ethernet) on an Olimex ESP32-Gateway. I can’t find any ethernet info in the docs for this board but the chip on the board is an SMSC 8710A. The pinout says “GPIO05, GPIO17 can be used only if Ethernet functionality is not used”.

I have been able to connect to WLED and control LEDs via WiFi without problem. I am trying to switch to ethernet.

I set the static IP address in WLED to My Mac and the ESP are Ethernet connected to a Netgear JGS524 switch and the Mac’s IP on that is

I have tried the ABC! wled v34, Quinled-ESP32, Serge74-ESP32 and Twilightlord-ESP32 Ethernet types (the ones which use GPIO pins 05 and 17).

When I turn wireless off on my Mac, “arp -a” doesn’t find the ESP32. Neither the static IP address nor the prior DHCP address can be found in a browser. I cannot connect to WLED via Ethernet.

When I turn wireless back on, the ESP32 reappears (with the prior DHCP address, not the static IP address I set).

Note I am not a networking pro, just winging it.

Any advice please? Thank you.

Looking at the schematic it should be either QuinLed or Serg74.

Note that if you set a static IP you need to set the Gateway field too otherwise it won’t connect, make sure the netmask is correct too.

If those modes don’t work, it’s not that difficult to add support for you to a new ethernet board usually!

If one of those modes do work, it’d be nice of you to document it in the knowledgebase for the next person :slight_smile:

Thank you for the quick response!
I reset the static IP address back to (messing with gateway is over my head). The Client IP address still shows (previously assigned by DHCP) in the WLED WiFi config screen. I tried both QuinLED-ESP32 and Serge74-ETH32, both times reseting the ESP32 (using the onboard RST button) after saving.
No luck :frowning:
I’m going to sit with someone that knows more about networking than I do to see if I’m doing something wrong with settings but I am an engineer and have done a lot of digital work (meaning I’m methodical and generally understand technology, so feel I’ve done everything right).
But any further ideas or advice would be greatly appreciated.

Thank you-

Thank you!
So far no joy.
We’ve built a 16,000 LED installation with 25 ESP controllers for this year’s Burning Man in late August. All the dev and testing was done with WiFi and it didn’t occur to us that there might be an incompatibility issue with WLED/ Ethernet. Our intention was to run it on Ethernet to avoid WiFi problems (on WiFi we see occasional white flashes and WLED master/ slave synching is glitchy).
So WiFi is plan B but not a great Plan B.
I really don’t relish going out to identify a new ESP board and rewiring/ rebuilding 25 controllers, so YES! adding support for this board in the near term would be amazing.

How would I go about requesting this?

This is the board we used: ESP32-GATEWAY Olimex LTD | Development Boards, Kits, Programmers | DigiKey

Thank you-

Assuming the netmask is which would be standard for that range those wouldn’t be on the same network and thus not be able to see each other. My guess is something’s wrong with your network setup and your wifi/ethernet don’t talk together.

Thanks again for followup.
I should have clarified in my followup post to your QuinLED/ Serge suggestions.
I had also set the Macs IP address back to on the ethernet switch. The netmask is The Mac and the ESP are both 192.168.86.XX. Still no luck.
I’ll sit with my network friend this weekend to see if he sees anything I’m not seeing then followup on Monday.
Have a good weekend!

Nobody claim to test Olimex ethernet boards. There are few boards made by WLED community and standard ethernet boards already tested and used. For fast result better to use tested boards. Otherwise you have to consult docs from Olimex to make it functional if possible.

Thank you. Can you give me a hint as to what I’m looking for in the Olimex docs and what to do with it when I find it?

They give sample code here

The pins and modes match the Quinled definition in WLED

so unless there’s something weird it should work…

Did you try another board or done all your tests on the same?

Happy Monday-

Thank you for taking the time to research the code.

I tried a couple of boards with the same (negative) result.

I decided to order a new board based on the list of supported boards and am waiting for two Olimex ESP-32 POE boards in a couple of days. I’ll send an update on what I find.

I hope they work!