One particular WS2812B Strip not working with Wemos D1 Mini

I have a 2M (30 LEDs/M) WS2812B that is giving me headaches. Only the first 1 or 2 LEDS will light up when connected to my Wemos D1 Mini’s. I have tested the strip with 4 D1 Mini’s. I can plug in other strips to those D1 Mini’s and the other strips works as expected. It is just this one strip. I have tried to troubleshoot and below are my tests, but can’t make sense of my results.

Troubleshooting Tests: LED Preferences set to 60 LEDs.
Strip does not work with 4 different D1 Mini’s (Shows 1 white LED. sometimes 2nd LED different color)
Strip will work if I power up D1 Mini first and then plug in the strip
Strip will work if I daisy chain it as the 2nd strip. First strip is a 156 LED strip. (LED preferences set to 216 LEDS)
Strip works with SP002E USB connector
Strip works with ESP32 DEVKITV1 with WLED
Strip works on Lolin NODEMCU v3 with WLED

Please try adding a 3.3k or 4.7kOhm resistor between the data pin and the 3v3 pin. If you don’t have the resistor available, try using pin 1 (labeled TX) instead of pin 2 (labeled D4)

Thanks for the reply. I only have 1k and 10k resistors handy. So I moved the data line to pin 1 (labeled TX) and adjusted it in LED preference (GPIO 1), but still didn’t work. I tested other strips again and they worked fine.

I forgot to mention that previously I also tried to bypass different amounts of LEDs on the line just to see maybe there was an issue with the counter or something in the first few LEDs, which, of course, didn’t help either.