Presets Cycle Transition


I installed 5 meters of LED at my living room window with WLED (typical Christmas light :-).
I have 7 presets and use “Presets Cycle”. I would like to have 3 seconds transition but the setting always come back to 0.7s.

Did I miss something?


Are you running an older version than current? That was fixed.

Yes I’m running the version 0.11.1
Any other subjection?

When you are making changes to the presets, are you making sure the preset(s) is “checked” for saving changes? I think of it as “listening” when I see the checkbox on the left of a preset. To me, that means when I make a change from the WLED interface, that preset will accept any and all changes and make them part of their preset. Then I just need to save the preset(s) so they keep them.

Hi @huggy-d1,

I’m talking about this setting:

Are talking about the same think?

You must uncheck “Preset cycle”, adjust the time, then check it back on.

Hi @Red-White-Blue,

I follow this process but the transition comes back to 0.7s after a short moment.
My two WLED rigs have the same issue. I’m using Home Assistant and Node-Red integrations, this may be related.

Edit: So I build a third WLED without connecting to these integrations, the problem still presents :frowning:

Are you able to change the “Time per preset” and have it save?

Yes “Time per preset” work get saved

I’m seeing this as well in ver 0.11.1. It didn’t keep reverting back in ver 0.10.2

I’ve also changed the config, led preferences, Transition time to 1500ms as I require a master setting 1.5 sec’s of transition however it still reverts back in presets after a cold start to 0.7. The transition master setting remains at 1500ms.
Changing the time in the favourites section to 1.5 secs and checking the presets box only works until you make another pattern selection. It then reverts back to 0.7 which is the default.

Thanks, @Modelman, I feel less alone :slight_smile:
This may get fixed for the next version.

I try to change the transition with the config preset:


The transition number is correct in the WLED interface, be presets still jumps from presets without any visible transition.

There were obviously a lot of changes involved to integrate the new filesystem in ver 0.11. In doing so a few minor issues may have crept in that now need addressing. It’s not really a big deal as most people are probably happy with the default 0.7 sec. I personally prefer a more gradual transition.

I’m using my led on the back edge of my desk. So it very visible when I’m working on my computer. Soft transition will be welcome :slight_smile:

Look forward to try the next version of WLED.