Problem with boot after initial setup!

Hello WLED Community! :wave:

I have a strange problem.
After I install WLED via “” it works perfectly while it is still connected.
But when I unplug it and plug it back in via Micro USB or even on my 5V external Power, it just won’t come back up.

But when I connect it and press install on install wled me:

It is here again:
Without it installing, it again. Just connecting.
It also has everything saved from my previous settings.

My ESP board:

Hope someone can help me. It is very frustrating!

Have you tried without the board connected to any LEDs?
Watch out for the pin besides the 5V pin. It is NOT a Gnd pin, it’s labelled “CMD” and can’t be used (connected to GPIO11, SPI flash)

Also look for the WLED AP if the board is not saving your WiFi settings correctly.

Thanks for your fast answer. The AP is not coming up. I haven’t used any pin by now bc the LEDs are not connected yet. Only thing that is connected is micro USB to USB-A on my PC.

Maybe try with and external 5V power source.

I seem to recall seeing a few posts about that series of boards causing some issues.
MIght be worth a hunt through the forum and see if anyone else has had similar issues.

Yeah, that was one of the first things I’ve tried.
I also tried other USB cables.

I have looked around here, but none having the same problem.
Also tried some of the solutions, but nothing fixed it.

I solved the problem!
You need to install the bootloader by yourself. You can then use to install the Firmware after.

Here is the solution:
python -m esptool --chip esp32 erase_flash

After you erased the flash, with this command you need to look at the output, it will tell you what board type you have.
In my example, it writes this:

Chip is ESP32-D0WD-V3 (revision v3.1)

I found out for this chip the bootloader should be at: 0x1000

So you need to do this:
python -m esptool write_flash 0x1000 ./esp32_bootloader_v4.bin

**BUT ** I have a new problem… the device starts, but won’t connect to my Wi-Fi after i plug it of and on again. :smiling_face_with_tear: I look into the forum maybe someone had the same issue and can help me.

I would say this here is SOLVED