Turn on infrared in wled sound reactive

Instruction to find wled.h file and turn on infrared

We have also disabled functionality for other interfaces, such as Alexa, Blynk, Cronixie, Huesync, Infrared. If you would like to enable them, you will need to modify wled.h

Is this a question or a statement?

Sorry a question. The first part I’m asking how to modify the wled sound reactive 12.0 The web says there was no more space on the chip so certain things were disabled. I need to use use the infrared. I use an esp32. I want to download the file I need for esp32 and it’s only in bin extension. Not sure if it can be converted to modify or change settings in arduino. The second part was text from the wled GitHub website. I was able to modify the esp8266 as the source code is downloadable. But I have moved up o the esp32 as esp8266 I believe will be not used in future wled projects. Well more the smaller memory modules. The wled sound reactive in GitHub states that you need to modify. I just need instructions on where to start

Follow the guide on kno.wled.ge

1 Like

Thank you. I’ll try it out later.

Well I got as far as compile (platformio). Where do I find the bin file to flash

Should be in “.pio\build\esp32dev\firmware.bin” under the tree you’ve assigned to your project (thats the Win version).
The .pio folder may be hidden, so you might have to do a little hunting.

I downloaded gig client but there are no instructions of what to do with it?

Thank you. I’ll check it out

I followed all the instructions but can’t figure out what to modify in VS to turn on the IR. Pin. Can someone guide me please?

If you have your ESP32 board connected you can also choose “upload” instead of “build” in platformio and it will just push it to the ESP board instead of having to build, then flash.

Thank you for your help. I tried what you suggested and it uploaded but still doesn’t work with the ir. Is there something to uncomment or comment to get the ir function operating. When I try to change to #4 for led pin in led preferences after saving it reverts back to -1. I’m using the esp32. What am I missing or not understanding? Please help me. I getting frustrated

Try setting IRPIN in platformio.ini -D IRPIN=4

I tried your suggestion but I cannot still change IR pin in led preferences from -1 to 4. I tried the remote anyway and it didn’t change or do anything. I was able to upload an older code and was able to set IR pin to 4 in led preferences and it all worked. Any other suggestions or written instructions to get the IR receiver section working in the newest code?

I figured it out. Thanks for the help guys. I modified wled.h to get the IR working