Two 8x32 Matrix Panels Stacked as 16x32

I have two 8x32 WS2812b panels. I want to use them to behave as a single 16x32 panel (vertical orientation). I tried everything I can think of to get them to act like 1 large panel. I had no issues getting them to work horizontally (8x32 next to the second 8x32, scrolling text scrolls off 1 onto the other horizontally). I am just using the JST plugs on my bench for now and I have one plugged into the other (being fed by 5v PS - I can do it properly with injection later once I get it working).

Is there a way to configure this? I am running WLED latest from GIT that I compiled with sound reactive usermod. Not really sure what the top section is even for in Matrix view, but I tried setting that to 32x8 (it does width first) and I tried 32x16. I tried flipping horizontal and vertical and I am using serpentine, but its all guessing and no combination ever gets both panels working. 1 works fine, but when I add the second one, the first one goes dark (second one acts like its the only panel). I have total LED’s set to 512, I tried 2 panels on the matrix settings (and tried defining as one big panel). Also tried adding segments, but nothing is working out for me.

Anyone got any ideas I can try? I feel like I’m missing something simple, or I just can’t do what I am trying and have to get two 16x16 to make this happen…


I’ve got something working but can’t get some effects to work.

  1. LED Prefs - set your total number of LEDs and max power etc.
  2. 2D setup - under panel setup, set the panel size, so 8x32 or 32x8
  3. Once all that is done, go back to the front page where you select colours, click info and Reboot WLED. When it reboots you should get both panels lighting up.

The setup of panels isn’t straight forward, I assume this is because the option appears new. I have a few ideas on how to improve it which I’ll probably add to the suggestions forums later.

Finally got it working with some help from discord. The trick is to set two panels 8x32 vertical serpentine, then set the Y offset of the first panel to 8. Here are the settings I used, before I added the offset.

Hope it helps someone!

Your screenshot does not show Y offset being 8 which should be correct.

I literally state that if you re-read:
“then set the Y offset of the first panel to 8. Here are the settings I used, before I added the offset.”

You should always show correct or final state. Not the wrong one.

1 Like