WeMos D1 R2 ESP8266 + 32 Mb flash WiFi RobotDyn + WLED ESP8266

I bought WeMos D1 R2 ESP8266 + 32 Mb flash WiFi RobotDyn with the idea of uploading WLED. Unfortunately, nothing works. I am uploading the WLED_0.13.0-b2_ESP8266.bin firmware. The installation process itself ends correctly, I tried through the site install.wled.me and by flashing the bin file. Unfortunately, nothing can be done anymore because there is no wifi network. The wifi module itself is functional because before uploading the WLED, the default name of the device’s wifi network appeared. Will it work at all or should I buy other controllers? How to check if the firmware is uploaded correctly?

When you tried to upload you had the serial port connected correct? WiFi only comes into play after flashing.

Also you may need to ground gpio 0 to enter flash mode.

WiFi was activated, the WLED-AP access point appeared after flashing and restarting the device. The only problem is that I was able to do this on the software version [WLED version 0.5.0] WLED_0.5.0_ESP8266_RGB_1802222.bin. WiFi does not turn on on a newer version of the software.