WLED and Home assisstant integration

As a standalone, my ESP32 works perfectly with the built-in WLED app. No worries about network connection or anything like that.

My HA setup (raspberry pi) picked it u and I chose to integrate.

Now, in the HA Device age, it says the following:

# Device info
Firmware: 0.13.1
Hardware: esp32
The device is disabled by Config entry.

I am stuffed if I can find the config it is making reference to. Any pointers to getting me on the right path would be appreciated!


yes the integration is disabled as indicted, to enable it back , follow the below


So it integrates but is disabled as default? This is the first time I have installed it and I have not disabled it.

I have…

and this…


… followed by this after clicking Configure.


… and I am limited to one attachment per post currently.

Why does the MCU show under ESPhome , did you use that same MCU with esphome before , you might need to do a clean up of old setting in HA , delete the integration and add wled again

By MCU I presume you mean the ESP32 running WLED, if so, I have no idea why it shows under esphome and I guess by your question, it is not supposed to.

I shall try to remove and reinstall the integration.

Thank you.

yes I mean the ESP32 and it should show you something like this

Tried removing and reinstalling, still shows ESPHOME on the device page…

So wled is working correctly on its own ? can you ping the ip from your PC and from within HA terminal ?
it might not be possible to do anything remotely as I cant see your other HA settings

For a quick help , might be drop by the discord WLED

As per my first post, yes, wled is working perfectly via browser access on PC and mobile.

I am trying uninstalling ESPHOME and WLED and see if it helps. I’ve only got a couple of temperature/humidity sensors hooked up, so it’s an easy setup.

After uninstalling Esphome and Wled, then installing Wled first, it now works properly.