Hi. I’m running the latest version of WLED. Also have it integrated with the latest version of Home Assistant. I’m noticing more and more that when connecting to WLED’s GUI from web or phone often reports my device as being offline. However, HA seems to be happily in contact with it. Does running Home Assistant somehow take the driver’s seat and provoke this behaviour? Or is it just a coincidence? When I can get into the interface it shows that the signal strength 78%. Thanks!

I’ve had WiFi dropouts on some cheaper ESP8266 clones even without using HA . There’s certainly some boards in circulation that just don’t seem to be able to retain a constant WiFi link. I’ve also read about other brands having very limited range, sometimes only a few feet from the router. Not experienced this with any of my ESP32 modules however maybe I’ve been lucky.
Not sure about whether HA takes any sort of preference as I’ve not used this feature yet.

Hi. If it was actually the module dropping it’s wifi connection - Home Assistant would no longer be able to control it. Yet it can. I don’t think it is a hardware issue based on that. But thanks for your interest.

Hi @picturemil, there is an option in the WiFi Setup called “Disable WiFi sleep” (it’s the very last one) - you can try this to avoid the module from powering down the WiFi signal strength…

That is brilliant. I have some Tasmota devices where I have to set Sleep 0

I have a feeling your tip is going to solve my problem. Thanks @Def3nder

i have exactly the same issue. It works with home assistant but i cant access the webUI or even ping it. But HA is able to control it. Any ideas?. The “disable WIFI” didnt fix the issue. THere must be a valida connection as HA can control it, but i cant access the webGUI

i did some more troubleshooting today, and the issue is very very strange. Basically the host where homeassistant is running can see the device and it can be pinged from it. Now, from another device in the same network, same IP range, etc. It CAN’T ping the device. If i reboot the WLED it will see it for a while then it goes away. But the device that runs home assistant can always see and ping the device.

Any ideas?

Hi. That’s interesting. That’s largely what I am still experiencing. Even though the WiFi is not being allowed to power-down now, It still wouldn’t really explain why HA has such success connecting and staying connected - whereas when the webGUI tries to share the love it gets rejection. Thanks for your testing. Hopefully one of the developers like @Aircoookie see this and have some expert insights to share. That said, changing the Disable WiFi sleep setting did improve things but I still have GUI instability.

i turned off home assistant. and basically some devices in the network CAN see the device, but not others, that is the issue. So when you say wifi goes away, in reality is only some devices that stop seeing it. Others will see it always. HA sees it b/c it is running in one of the network devices that can always see it

are you on a Unifi AP by any chance?

I did not summise that it was “WiFi goes away” - it was others that contributed to this thread that suggested that it might be a wifi issue. My starting post + early replies, match the behaviour you are describing. That being that HA seems to have elevated access and control over the module when using the HA WLED Integration. So whilst HA appears to be stable; connections from other network devices, either by pinging or by webGUI access fail.

No, not using Unifi (although I want to upgrade to their hardware when I can afford it.)

I did just read exactly the same problem on another forum.

For some weired reason some of the devices in the network could see/access the ESP while others couldn’t.

The solution was to disconnect the ESP (turn off the power) and then completely remove the device from the WiFi configuration on the WLAN Router (e.g. on a FritzBox going to “Home Network”, look for the device and hit the “X” aka Remove-Button).

With Unifi you could create a new separate WiFi network with only 2.4 GHz enabled and “legacy support” turned on - this did solve a lot of disconection problems at my site.

there is something weird going on for sure. What i did was to create another WLAN on UniFi with a different SSID and also created VLAN and assigned a totally different IP address range to the DHCP serving that VLAN. I used 10.10.x.x instead of 192.168.x.x for my main LAN and i see no issues since then


hi guys! any update in this matter? I am having exactly the same problems. HA can see the devices, but can’t access it from another device… using 0.13.0 b6 here… tried WLED and Sound Reactive Branch… same problems… using ESP32 and ESP8266… both with same issue…

Solved!!! Upnp was off in the router… turned on, and everything is working. Wled is udp dependent!

I am facing the same issue whereby HA has no issues controlling WLED at all times, but other Network devices will eventually no longer see the device (ESP8266 WLED 0.13.3) and the GUI is no longer accessible.

I have an LG Ambilight-like service called HyperHDR running on the TV, that relies on sending UDP packet to the ESP8266 running WLED.

For some reasons that will fail because of the pinging issue that sometimes occur…

You mentionned UPnP support at router level…What router brand was it for you ? ASUS ?

Are you sure this was what made it work.

Isn’t UPnP a WAN-level feature more than an internal LAN feature.

UPnP is definitely a LAN (or WAN) feature.
Personally I Hate UPnP and explicitly turn it off in my networks.

But if your router needs it…

For an ASUS AX86U, I can only find a UPnP related enable/disable in the WAN page…which had already been enabled. but this is not fixing my issue…

It’s often buried under other acronyms and/or functions for the internal LAN(s).
On the WAN side, you’re asking for a Protocol to anonymously punch holes in your firewall for you.
Not a prescription for safe data transfer in my experience.

That’s why I kill all that stuff.