WLED installation issue

I’ve downloaded the latest release (0.10.2 ESP8266.bin). However, when I try to open/install the file, it gives me an error message stating the file type is not supported. I’ve tried to install it to both a MacBook and Chromebook and get the same error with both. I’ve tried to open it with several expansion programs and apps. Nothing works.

Has anyone had this issue? How can I get this installed?

Sorry for the basic question and thanks for your help.

What are you trying to do ?

I’m brand new to the LED light game. Ultimately, I’m trying to light up strips of RGBW lights with WLED. I have all the hardware. I’m following Dr.Zzs steps and the first is to download and install WLED and then set up the NodeMCU. I’m trying to install WLED and the file won’t open.

Ok. First download ESPhome flasher. Connect your NodeMCU controller to usb. Open ESPhome flasher and then open bin file you downloaded from GitHub. Click flash ESP. Wait until code is finished uploading. Done.

Thank you for your help. Unfortunately, I’m still not able to open either the ESPhome flasher app or the WLED bin file. I changed my security settings to allow apps from unidentified developers and it still didn’t work. For the WLED bin file, I get a message saying: “Unable to expand “WLED_0.10.0_ESP8266.bin”. It is in an unsupported format.”

For ESPhome Flasher, I get a message saying “The application “ESPHome-Flasher” can’t be opened.”

So, I can download the files, but I can’t open any of them to install. I have a MacBook Air with Catalina OS. I’m at a complete loss as to how to simply open the files.

Something wrong with your computer. I also using Mac and everything working just fine.

Forgive me for being vague, but I found the flasher does not work with an older version of MacOS and I’ve forgotten the details. An update of the MacOS would have overwritten a version of QuickTime Pro I wanted to keep. So I bought a super cheap PC to run the flasher.

I download the proper Bin file using my Mac, write the file to a micro USB card, put card in PC and run flasher connected to 8266. This extra step is used to ally my fears of connecting a PC to the internet. I possess zero PC skills.

When Covid relents, I’ll go to store and I’ll buy a new Mac with updated OS that will run flasher.

I don’t have my laptop in my hands, when I do I’ll look up the OS number, Apple’s naming structure means nothing to me…bad memory…mine.

I know this is of no help, because it didn’t help me. My Mac has MAC OSX YOSEMITE 10.10.5. I felt it needed a USB to UART extension. If I remember correctly, I downloaded something from Silicon Labs. Of the 20 times I tried, it worked once. Or so I thought, it probably didn’t.

Then I read 10.10.5 is incapable of performing the desired function. A software update would allow the function to work and I would have been able to use a Flasher. I have chosen not to update. I use a $200USD PC laptop to flash ESP8266 Node MCU devices.

Sorry, to NOT be helpful.

Thank you. I’ve tried every fix that I can find and nothing works. My next step is to buy a cheap laptop just to try to run this program.