I have a dig quad and I flashed it just fine but cannot find the WLED-AP so now I’m stuck. please help me. also I’m very new at this.

thank you for any help!!!

You need to flash the esp32_bootloader.bin first. I recommend either esptool or ESP Home Flasher (i believe the latter will take care of the bootloader automatically, I’m not sure)


Thanks. I had to use the node flasher tool because home flasher would not open on my Mac. I’m hoping it’s good enough. When you say load that one first am I loading the one I originally used immediately after without pressing the full erase button?

I tried to flash twice. Once with each. The boot loader and wled. Still no better results. Am I doing something wrong? How am I the only one having this problem?

Thanks for any help!!!

You are not the only one. I bought an UNO and a Quad. The UNO worked fine and is in service, working fine. I can not find WLED-AP on the Quad. By itself, the onboard LED lights red. When attached to terminal board, the terminal board blue LED lights and the red LED is lit.

You need to flash it at different offsets as documented in the wiki link i sent :slight_smile:
This is only necessary with the ESP32, ESP8266 does not need the separate bootloader.

Since your flashing tool doesn’t support offsets, I tried to make a combined binary that includes the bootloader, but I’m not sure that it will work, but you can give it a try!

0110_esp32_combined.bin (2 MB)

Last night I used a windows computer with the home flasher tool. Everything seems to be working quite well now. I really appreciate the help from you guys!!!

1 Like

Combined worked perfectly. Thank you for your continued support of this quality project, WLED. I now have a solid red LED and a blinking blue and all programming through app was flawless.

If I choose to use the Quindor multi-pin BIN can I go directly to it and use “yes, wipes all data” ??

1 Like

Sorry I don’t know because it depends on what settings the binary was compiled with. But it will work for sure if you use the Manual OTA Update button in Security settings to upload Quindor’s binary!

Okay, thanks again! For now, gonna relax, enjoy new found success.

I have tried to download the boot loader and several different versions of it and I am still unable to find my ESP 32’s. I have flashed with the WLED 12.0, but every boot loader driver that I try to flash tells me there’s a firmware failure:

unexpected error: The firmware binary is invalid (magic byte=FF, should be E9)

I have recently switched from 8266’s to 32s and there has been changes to my symptoms so not feels like this is the main problem.

As additional information, I am running WS2812’s on 60A power supply and 2 ESP32s for roofline and wreaths. Right now I cannot discover any WLED, all of the length has pixels that are lit throughout it, but they are different colors and pixelation. This usually means that its the control line in my experience, so in need of some help at this point.

ESP8266’s just load the WLED firmware and go.
ESP32’s need the bootloader installed first, then load WLED firmware and go.
It is generally a good practice to erase either one first before loading if there are problems with the last firmware or bootloader install.

Try ESP Flasher or other such tool compatible with your computer to erase your ESP’s before loading WLED (or bootloader).

Also, handles the ESP32 correctly.

1 Like

How do I erase the ESPs with ESP Home flasher ?

I believe it erases by default.