Dig Quad Help

What’s up, guys!
It’s been a while for me since I’ve been on here. I’m glad to be back in.
I’ve got the dig-quad now and for the life of me I can’t get my one strand of lights to work fully, it partially lights up some on one end, and at the end of the string.
wled version 0.13.1
power: 5v
leds: 300
eabl: off
gpio: 16
color order: RGB

I’m sure it’s something simple but I can’t figure it out, so I’m asking for some assistance.

If I’m not in the right place please let me know and I will move it.

Thanks in advance,

How many lights do you have in total and what type/density?

How many can you get to light?

Have you tried a different GPIO?

Also check your segment settings.

And realistically, think about upgrading to V0.14.0 (stable release now).
Save your settings and presets first.

Thank you all for the replies.
So I have one string of addressable led lights (16ft 150 leds) for now, I can only get a few (17) leds to come on but they stay on constantly with power on or off within “wled” app.

What do I need to check on the segment side of things?

I was at v0.14.0 and still the same result.

under the esp32 their are 4 pins and they are all switched in a downward position, do they need to be in a different orientation?
I’ve tried 3 different sets of led strips and the same result.

Thank you in advance.

In LED Preferences do you have the GPIO set correct for the port you have your LEDs connected to?


Also the correct # of LEDs in the box?

From the Main WLED UI, under Segments. You should only have Segment 0. Expand it and see if your total # of LEDs are correct.

Those switches under the Esp change the resistor value for each port. 1 way is 33Ohm and the other way is 249 Ohm. You can switch them from 1 to the other if you are having flickering/random colors/flashing issues to see what value works best.

If you are trying to connect 300 5v LEDs and you are not power injecting you are very likely to have issues as trying to send enough power through the strip to power all the LEDs is unlikely due to resistance/voltage drop. Even 150 5v LEDs is pushing your luck without power injection.

Here are a few screenshots of my led preferences.

Looks like it should work if you are connected to LED1 on the controller.
Did you check your segments?

I don’t have any segments currently.

Here is what my setup looks like.

When it’s powered it seems that it is on, but when I open ‘WLED’ and click on ‘power’ it does nothing.

any suggestions?

Thank you,

I think you may be connected to the wrong end of the LED strip. Data only flows one way. Normally the end of the strip that looks like the connector you have there is the beginning. (someitmes not)

1 Like

Well Jinx, that did the trick (it’s always the little things).
I now have lights…ya!
I appreciate the help.
I’m sure I’ll have more questions later.

Thank you again.

1 Like