Wled v0.13.1 Toki audiorhythmic via wifi does not work with audio visualization app

Hello guys, I tried to make this project (IoT Bottle Lighting Pad by Surrbradl08 - Thingiverse), I did it as the tutorial says and I also tried to install the latest version (v0.13.1) from the web (install .wled.me) on a Wemos D1 mini board (ESP8266) and the led strip is WS2812B.
It works correctly from the Web interface and from the WLED App via WIFI but I can’t make it audio rhythmic, I have the Windows app “Audio Visualization” (Releases · NimmLor/IoT-Audio-Visualization-Center · GitHub /tag/0.1) in a notebook in the same WIFI network, the WLED web detects the UDP signal from the notebook but the LEDs do not work with the music.
I leave some images to see if someone can help me.

Thank you very much!

Have you tired LedFx? The app you are trying to use does not seem to of had much going on with it in over a year.

Jinx thank you very much for answering and for your help.
With LexFX the audio rhythmic works but it is only with the windows microphone, is there a way to not use the microphone and that it is only the music that windows plays?

I would think that there has got to be a way, but sadly I have not found it either. I do have the ‘what you hear’ option but that does not seem to work. You may want to see if someone knows on the LedFx discord channel. I don’t use it very often so in the past I have just put my headset mic by a speaker lol. I did try a little bit for a better input option but gave up. Bit hard for me to get the right device as my pc has 2 sound cards, usb speakers, 2 sound channels for my steel series arctis pro wireless headphones. So I just gave up and use the mic :upside_down_face: Sorry. Maybe someone else will chime in.

Well you got me looking LOL. I did a search at the LedFx Discord and came across a post talking about a program called VoiceMeeter. Looks like it creates a virtual audio input/output. One in your windows playback and one in microphones. Using this ‘virtual’ audio mixer I have LedFx working w/out using a mic.

Download/install from the link above.
Open the newly installed program from your programs list called

The 2 hardware inputs are for other sound INPUT devices you may/may not want to mix in. Ex: your Mic (nothing is needed in either HW Input unless you intend to use that for audio input). Virtual Input is the virtual playback device that was added when you installed the app. Hardware Out needs to be set to whatever sound device you want for your playback. Ex: your speakers.

In windows sound settings you have to have your playback device set to the virtual device that the program created (it did it automatically for me when I installed the app. It also changed my default capture device to the virtual one. *Capture device default is not needed). Pics of both windows sound settings depending on what one you use.


Then set your sound input in LedFx as the virtual output:

If you need any more help give me a shout. Thanks for making me get this figured out. It works so much better than using the Mic.

Fantastic, now it’s working great, I really appreciate your help, thanks for taking the trouble to do the tests to help me.

1 Like

Great its working . Just so you can check something , LedFx works for us on windows when we play audio in edge browser . It does not work with firefox . That is out of the box without any changes like you did

Interesting. What did you choose in LedFx for the sound device?

And I forgot to say i am using cheap analog headphones

Audio Input says Microphone HD Audio. That sounds like it’s using the 3.5mm mic jack on your onboard sound card. Guessing it’s the mic on your headphones? If not that’s weird.

yes it is using the 3.5 mm jack which is connected to my analog headphones and I think I seen someone saying that digital audio ( as in usb audio headphones ) will not work with ledfx but he mentioned that the analog will work . If you want to compare other audio setups in the PC we can also share that . I wanted to do voicemeeter but did not want to mess with the audio setup too much

Ahh gotcha. The idea of using the voicemeeter is so that it sort of works off Line Audio vs ambient sound the mic is picking up, while also still outputting to your speakers. If you decide to give the voicemeeter a try and run into any problems switching back to your regular audio let me know and I am sure I would be able to get you pointed in the right direction.

*Tip for anyone using VoiceMeeter: If you want to go back to your other audio devices you have to close the VoiceMeeter app or else you won’t hear anything no matter what device you set as your default. Of course you could just keep using VoiceMeeter and letting it route/mix the audio.

*Tip 2: If audio is not loud enough while using VoiceMeeter you need to close it and set your speakers or whatever device you use to listen with’s volume to a high or 100% level. Reopen VoiceMeeter and then use it’s volume controls to adjust the volume (probably down at this point). Windows volume and or the one on fancy keyboards will not do anything other than if you set it to 0, will mute the sound. From 1-100 does nothing.

I’m not sure why you were unable to get LedFx to work when using other browsers. It should as it’s getting the audio from your mic. Or did you mean the web interface won’t open on other browsers?

  • I just tested it on IE, Edge, Firefox, Chrome, and Google Canary. opened on all except IE. :slight_smile:

I just fired up my old logitech G933 wireless usb headphones and the mic on them is working with LedFx. So I can confirm that at least some usb devices work with it.

I am not really sure what do you mean by that because in our case ledfx is not reacting to the mic input but to the music playing from the edge browser .My mic is not picking anything because it is muted with a physical switch from the headphone . I did mess with my mac audio and created aggregate devices and that is not something I want to do the the PC but I think newer version of ledfx is much better and might work without tweaking PC audio too much

1 Like

Hmm that’s weird. I don’t know how it’s doing that, but hey as long as it’s working.

Not sure if you have it working on your mac or not. If not there is some info on that in the Docs section over @ ledfx site.

I have two machines ,
The PC running windows 10 which i sent pictures of , that PC is not running voicemeeter and ledfx is working , might be the headphone is seen as a loopback but again mic is muted . This could be a workaround not mentioned in ledfx docs but I seen other use ledfx without voicemeeter .

The MAC is having totally different setup and sound aggregate device is done for video editing but not related to ledfx

AhHa! I just found something on LedFx’s github. Looks like they don’t always update their site to match.

I have not tried this yet but this may be an alternative to voicemeeter. ‘Stero Mix’

Direct computer audio output to LedFx.

I will see if I can get that Stereo Mix figured out and see how that goes for the heck of it. Cheers!

No dice on that Stereo Mix thing. I can’t even see it. O-well I’ll stick with voicemeeter.

Yeah , Might be you should stay with voicemeeter , cause the way I showed is working but sometimes you have to keep refreshing ledfx to work , Actually since last update for my ledfx it is kinda feel its not that stable with sound ,might because we keep adding and deleting many devices . I was looking at ledfx discord and thinking there is a new beta version out but not really sure .

How are you updating LedFx? I see on git it’s listed as 10.7 but when I open the app it says checking for update and that it’s up to date. The interface says 10.5

updated from here a while back and mine also say on the interface 10.5 https://www.ledfx.app/download-ledfx/