WLED + V63 Controller + TM1814

I connected a decent 12V Mean Well power supply to the V63 controller from here: wled.shop | Shop, and attached 2 meters (40 sections of 3 LEDs) of TM1814 (RGBW) LED strip. The various lighting effects work fine (I think), but I can’t get the strip to use any solid color - both when I turn it on and when I try to set a solid color it falls into red light mode and flashes some LEDs.
What am I doing wrong?

You’ll have to post a basic wiring diagram.

What ESP are you using?

I’m using ESP-WROOM-32.

Mean Well 200W 12V is connected directly to LED strip power in with ~15 cm of cable and to V63. Signal cable is connected to V63 “signal out” connector.

Changed ESP to another one to make sure it isn’t hardware issue, then flashed it with 0.13.1 instead of 0.14.0 - now it works, but LEDs flash red from time to time… one problem solved, another one to solve :frowning:

I would use the controller working under 0.13.1 and bring it up to 0.14.
It should be a matter of getting the correct settings to drive the strip.

Did that. Works with 0.13.1 and 0.13.3, fails on 0.14.0. Had to revert back to 0.13.3 :frowning:
Is that correct setup?

Zrzut ekranu 2023-10-29 103004

The TM1814 setup under 0.14 is similar but adds the option to “Swap W Channel” with one of the other (R, G, B). This accommodates some strips that have usual colour order (GRB for eg.) but the added W channel is not 1st or last, but swapped with one of the other colours. You can get the correct value for your strip by setting a single solid colour with the W channel at 0%. As you try each of R, G, B your strip will give you some solid colour, if it matches what you set then you’ve got that channel in the right order. Otherwise you’ll have to try a different order.

If one of the single colours you ask for comes up White instead, that channel has been Swapped with W.
You should change that in WLED.

As far as flicker, try with smaller #'s of LED’s (try 20) at reduced brightness and make sure the automatic brightness limiter is disabled. If you’re happy with the colours and effects, try increasing the number of LEDs gradually and then brightness. That should help isolate any potential power issues.

Tried exactly all the combinations (GRB, RGB etc.). with all the “swap W channel” modes. No “swap W channel” option even seems to be saved/applied, though. Reverting back to 0.13.3.

Red blinking isn’t about power issues for sure - I’m testing “night mode” on which only every 10th LED group glows on 10% off the nominal power. My whole set takes 7.15W @ 12V…

I just got some pixel pucks with 12v TM1814 and I’m seeing the same thing using Digiquad. My WLED is on version 0.14. If I set to TM1814, all LEDs turn red with every 5-10 led flickering. If I try to change colors or set an affect, the LEDs might flicker then the go back to this red state with some flickering.

I’ll have to try WLED with 0.13 to see if it starts to work like yours.

I was able to reproduce the exact same outcome. Firmware 0.14 TM1814 does NOT work. I reverted back to 0.13.1 and TM1814 works as expected (though this firmware loses the swap function).

I’ve read older posts that seem to show that TM1814 can be affected by interrupts or other processes going on. So I’m wondering if some added features introduced from 0.14 is causing the issue. Maybe if some added features are turned off?

Might be time to make a Github post with the issue.
Most other items with 0.14 have been very solid.

Does 0.13.3 work for you? I believe that has the W/Swap option.

Have you got a link for the pixel pucks that exhibit the issue?

1 Like

I got 0.14.0 working, I had to disable the “Use global LED buffer”. Once that is unchecked and saved, TM1814 works as expected. I’m not sure what that setting does. I couldn’t find information about it in the docs.

I’ll have to check 0.13.3.
Here is the link to the LED pucks I got from Way Ru: https://www.aliexpress.us/item/3256805073853110.html
( I purchased because I thought they were UCS2904 , but support confirmed they are actually TM1814 chips)

if you go to the LED settings and uncheck “use global LED buffer” that worked for me.

That’s very interesting, good find!

It would be really worthwhile if that ended up in Github so this issue could be followed up.

I have created a bug: TM1814 no longer works with the release of 0.14.0 · Issue #3514 · Aircoookie/WLED · GitHub

1 Like

Do you know what the global LED buffer is used for?

It’s the buffer that holds the color data for all LEDs.

what do I lose by unchecking it? Is there an expected limitation on effects or number of pixels supported etc?

Just received QuinLED-ESP32-ABE controller with ESP32 and LAN. Same TM1814 strip as used with V63 controller, 2 m long. Still getting random red flashes every few minutes, no matter if LED is on or off, as long as it uses constant (solid) color.

This is with the LED buffer off?
I was able to fix it under my limited testing with the buffer off, or by going to change line 83 in file FX.cpp to return 50 instead of 350 and compiling my own bit file.

see the git issue ticket for more info:
TM1814 no longer works with the release of 0.14.0 · Issue #3514 · Aircoookie/WLED · GitHub

Depending on wiring did you try and flip the resistor switcher to 33R mode (beneath the ESP32 on the Dig board)?