Alexa respond

HI, i’m using the last WLED 0.9.1 on an Wemos d1 mini 3, and works perfectly. But when i say “Alexa, turn on lamp”, alexa turn on the lamp but say me “device not responding check…”.

Please help me. Thank you

you need to discover the divice first via alexa app. Moreover you need to have an alexa device/speaker like echo dot to get w-led to work with alexa voice controll

Yes, i have an echo dot 3. I discover the WLED and for the first time it works, after that i say “Alexa, turn on lamp”, alexa turn on the lamp but say me “device not responding check…”.

A new version of wled 0,10 is now available.So try to update to the newest version. Moreover there is a “Alexa emulated device” check box in settings especially in sync interfaces make sure that there is everything right(giving a na,e to your device may help) and last but not least delete the device from alexa app and try to search and install it on alexa again . Oh almost forgot it dissabling Wifi sleep may also work for you. If nothing of that is going to work i highly recomend to send a personal message to Aircookie

How do I discover WLED in Alexa? My Amazon Echo 3 doesn’t find anything. Nor can it control the strip.
Installed it today.

Have you found the Alexa WLED setting? Did you give the WLED device a name that it can be found by? The WLED Wiki settings section ( has this:

Emulate Alexa device Y/N Allows you to control the light via the Amazon Echo voice assistant. Requires reboot
Alexa Invocation name String 1…32 The name you want the device to have for control via Alexa. Choose something easy she can understand

Yes of found the Option in the sync menu and booted wled New. I think Ambientlight should ne a easy name. But when i want to discover nee devices it finds nothing.

Can you explain me which steps i need to make?

Tried discover new device and then the last option: Sonstiges Gerät in the Alexa App.

So, you have “Emulate Alexa device” set to Y, and may I suggest splitting the name into 2 distinct words to help Alexa understand (once it discovers the wled device) more easily. I may be wrong since I only know Alexa with English. Try Alexa name “Ambient Light” rather than “Ambientlight”. Should not matter for discovery.

Did you install default firmware downloaded from the WLED github site under the releases section, or is it custom firmware build? If you downloaded default firmware, which one, and which device do you have?

The WLED Wiki section about installing firmware ( ) says these binaries have Alexa support disabled [I doubt this is the problem, but just in case]:

1 Like

Per this:
Ensure your wifi / router had UPnP enabled. Apparently this is how the echo performs the discover without a skill.

1 Like

I found the issue!
The WLED was in a subnet (therefore other WLAN) and so ALexa could not find it.
Changed the WLAN to test things and it works now :slight_smile:

Thank you for the help and fast responses.