Unable to find new Alexa devices with 0.9.1

I have built 3 new strips with d1mini and Alexa won’t discover any of them. My initial two that were running 0.9.1b and updated to 0.9.1 still work with Alexa.

Emulate Alexa device enabled
Attempted with send Alexa notifications enabled & disabled

According to the WLED Wiki, you need to give the WLED device a unique name for Alexa to use, and then enable Alexa option:

Emulate Alexa device Y/N Allows you to control the light via the Amazon Echo voice assistant. Requires reboot
Alexa Invocation name String 1…32 The name you want the device to have for control via Alexa. Choose something easy she can understand

I am not sure if the macro is required for the Alexa On/Off to work, but you might want to try that:
Alexa On/Off Macros 2x 0…16 Which macros to trigger when turning on/off via Alexa

Still no go. I can’t discover the new wled devices.

Tried changing both to unique names, then used the built in save and reboot.

Tried discovery with the Alexa app and my echo show 5.

Did the new wled devices come up in AP mode, you connected and setup the wifi details and restarted WLED, and now they are not pingable?

i have the wled devices up and running. my issue is alexa integration, i can control them from browser or android app without issue

My apologies for misunderstanding the problem.

What version of WLED is causing problems? When did you download it?

Do you still have the .bin file that works? If that .bin is loaded to any of the problem WLED devices, does it suddenly start working?

Hi @Cwcb08,

could you please write which binary you did use ?
Not all of them are “Alexa-enabled” - but all display the Alexa checkboxes in the settigns.
So we need to ensure using the right binary first…

I think I used “WLED_0.9.1_ESP8266.bin
535 KB” but I’m not home until 2moro to check what is saved on my computer

Not sure what happened because I’ve been away from home but when I opened my Alexa app while playing with another skill a device discovery located both strips at home.

Thanks guys.

hi @Cwcb08, glad to hear that it does work now :smiley:

Mine come up as Royal Phillip smart device.

I’m having this issue with WLED_0.10.0_ESP8266_apa102.bin and Wemos D1 mini. Is this Alexa enabled?