Art-Net First/Last Pixel of Universe Blue Flicker

Hi!

I’m using WLED on the ESP8266 as a wireless Art-Net receiver that is mounted to a variety of musical instruments (guitar, bass, keytar, drums, etc) for a show that I’m creating.

Despite almost everything working great, I’m experiencing a single blue flickering pixel at the end/beginning/transition point of each Art-Net universe (some of the instruments use 2-3 universes).

I’m using multiple types of WS28xx strips and it seems to be happening no matter which kind I test.

The software I’m using to send the Art-Net is called MadMapper. I’ve also tried sending Art-Net with QLC+ and am experiencing the same issue. It does not occur with E1.31, but MadMapper doesn’t seem to work with E1.31 so it looks like I’m going to be stuck with Art-Net.

Could this be due to some sort of differing universe length definition? (510 vs. 512?)

I should also mention that everything functions perfectly fine when I’m not using Art-Net.

I’ve also contacted MadMapper about this issue but figured I would post here since it’s happening with multiple Art-Net sending programs.

Thank you so much for such a great piece of software. Please let me know if there’s any information I left out that could be useful in helping to figure this out.

Alex

Hi!
Thank you so much, I am very glad that you like WLED!

Other users have reported this blue led issue at universe boeswea a well. WLED does not yet support “splitting” a single LED across adjacent universes, therefore each universe should only have a length of 510 channels, which corresponds to 170 LEDs. I realize that a lot of software sends the more standard 512 channels per universe by default, I hope that will be supported in the future :slight_smile:

1 Like

The blue flickering pixels are happening with most Artnet outputting software since they all seem to send channels 511 and 512 with blank information. One exception is Jinx - if you don’t patch channel 511-512 it doesn’t send out anything, so no blue pixel flickering.

Here’s a workaround I came up with: Use MIDIMonster to convert the output of Madmapper/MADRIX/Resolume Arena to sACN, and filter out 511-512 while doing so. You can run MIDIMonster on the same local machine as Madmapper/Resolume etc., it hardly uses any resources. The Artnet destination IP in Madmapper is your own machine’s local IP. MIDIMonster receives it, converts to sACN and knows from the config file which WLED IP to send the sACN universe to.

Your MIDIMonster config file will look something like this:

[backend artnet]
bind = your local IP

[backend sacn]
bind = your local IP

[artnet in1]
universe = 1

[sacn out1]
universe = 1
destination = your WLED IP adress
priority = 100

[map]
in1.{1…510} > out1.{1…510}

This basically discards channels 511-512. No more flashing blue pixels - yay!!

1 Like

Hey!!! Ah that makes sense! I will try this out, thank you so much. I wonder if it is also possible to do the same thing but keep the “output” protocol Art-Net? I will mess with it. Either way this is a great workaround, thank you for the idea, going to go download MIDIMonster now.

This should theoretically work translating Artnet to Artnet, yes. You’d have to dive a bit deeper into MIDIMonsters documentation and probably use some Artnet loopback tricks instead of forwarding to another protocol.

I have the impression that sACN performs a bit better with WLED though (less lag, better response). But that might be just some unscientific feeling.

1 Like

Are you running MIDIMonster on a Mac? I’m having a hard time installing it. I tried downloading the macOS binary and installing it that way but when I run it I get:

“Failed to open plugin search path ./backends/: No such file or directory”

(Maybe a permissions error or something? I’m the administrator but I don’t have root enabled or anything like that)

I’m not the best with the Terminal. I also know this isn’t entirely WLED related so I understand if you can’t put time into helping me with it, or if it wouldn’t make sense to ask for help here on this forum.

Any help is greatly appreciated, including all that you’ve done so far!

All Windows 10 here.
You need the subdirectory with all the backend functionality as “plugins” (sacn, artnet, midi, mouse input etc.). Once unzipped it should all be in place.

Check if the directory is actually there. And then there’s obviously the horrible privilege thing under recent OSXs which I’m very very happy to have left behind me :slight_smile:

You don’t have to actually install anything, you just run MIDIMonster by dragging your very own config file on the MIDIMonster binary (at least that’s how it’s done in windows) - Check the MIDIMonster documentation.

It’s very powerful but also very very very not user-friendly (and there’s no GUI at all). But that’s mostly the case with powerful software :slight_smile:

1 Like