Board constantly going offline until reboot

Describe the bug
My wemos d1 mini (I think it’s a knockoff) will connect to wifi with the firmware just fine but then it goes offline. It stays offline until I reboot it. Then it goes online for another 1 minute and then it dies again. I have already seen some people with a similar issue which is #424 I seem to have tried everything on that issue list (including building my own firmware and doing the ping fix) with no success. I have tried to compile different versions and older versions and nothing seems to work. I have my esp in a box outside running some fancy Christmas lights but it does the same thing when it is in my room right next to my router. I just wanted to see if anyone else has this problem and if anyone can help me out.
To Reproduce
I connect to the access point, I get it on my network (I have an amplifi instant wifi network if it matters) Then it boots up and goes offline after about 30s to 1 min. Then if I power-cycle the board. It goes back online and repeats the process.

Expected behavior
I expect it to boot up and stay online

WLED version

  • Board: [D1 mini]
  • Version [A bunch but I have been working with 10.0.2 and 0.11.0 (the newest one)]
  • Format [I have used bin files and compiled by myself using platformio and it makes no difference.]

Thanks to anyone with any ideas!
Edit: the connection to my network is not faulty, the webpage just goes down
(this is copied straight from github)

When it reboot is there any leds connected or is it by itself?
How are you powered also? Are you sure it is rebooting vs just dropping network.

On the network. You site amplifi instant connect are you using any type of features for connection or are you simply entering the ssid and password. Have you tried connecting to a ssid that is only 2.4ghz I have seen people complain about 5ghz causing issues but I have never experienced it.

Continuing the discussion from Board constantly going offline until reboot:

I’m sorry I might have confused you. The board doesn’t reboot by itself, it goes offline until I reboot it. After reboot, it goes back offline again after about a minute, then to get it back on you have to reboot it again. And it doesn’t disconnect from my router, the web page just goes down. And for power, I am running it off of a wallward 12v 3amp power supply with a string of 50 LEDs and a buck converter to convert 12v into 5v. After the webpage goes down, LEDs stay the same but I can’t change them. So I don’t think it’s the board rebooting I think it’s a problem with the webpage staying up. Board rebooting is just a temporary solution.

Does your buck converter have a common ground?

Does the d1 mini do this if no
Lights connected?

My buck converter just has a positive and ground. I don’t know about the common ground but I don’t think it matters. I don’t think it is a power problem because I have powered it with a 5v supply and it does the same thing. And even powered with a USB, the issue still prevails. It also doesn’t make a difference whether or not the leds are connected or not. I am inclined to believe that this is a software issue because I have had it working with this hardware before. Thanks for taking the time out of your day to help me.

Did you recently install a new home WiFi AP / router? Update firmware on existing? New microwave or zigbee or zwave hub? Damaged microwave door? Anything else having troubles with wifi in the same area as the WLED board? If you have WLED 0.8.6 available, try installing that to see if it gets better. These are all odd questions, no doubt, but your issue is rather odd, so more information about anything that has changed within the area it is placed, or between the AP/router and WLED board.

Find the setting that disables WIFI sleep in WLED and make sure it is not allowed to go to sleep.

I have done some of these things like tried the WiFi sleep. No new AP’s though. I don’t think this has anything to do with WiFi connection because it still shows up in my router even when it is not working right. I think it is just the webpage being wired it stays up if I refresh it often to re ping the board. I was into a solution on git hub that has worked for many people. Basically it just pings he board repeatedly. The wired thing is that that didn’t work. Thanks for your idea and I hope you have another one. I now realized that I explained the issue poorly and I’m sorry for that.

Do you have another wireless access point you could try it with? I see some people do have this problem, but many others have no issue. I am really thinking it could be the access points the wled boards are tying to.

Also, maybe you could load espixel stick software see if it does the same thing or not. Might be worth a try. It uses many of
The same
Libraries as wled. I know at one point in the past I had an issue with espixel stick when I compiled, vs using their binary. It was a supporting library that had a version conflict. Did you load wled binary or compile yourself?