Wemos D1 mini reboots at connecting to AP


My Wemos D1 mini reboots every time when I try to connect to AP. Sometimes I successfully connect to AP and I enter the main menu but after a few seconds, it reboots again.
I flashed it using ESP Home Flasher and esptool, and I tried 0.10.0, 0.9.1 and 0.8.5 versions.
I suspected it was a power problem so I added 2 caps of 470uF in parallel (I only had that in hand).
Tried powering it via USB from a laptop, phone charger, and 5V 40A LED power supply.
I managed to tick disable WiFi sleep option (that time connection lasted 20-ish seconds), and that did not help at all.

Currently, I can’t get hands on new Wemos board or NodeMCU to try if this board is faulty so I need to check whatever is possible with this board.

I get this when i try to connect to AP:

[19:43:25]Exception (0):
[19:43:25]epc1=0x40257044 epc2=0x00000000 epc3=0x00000000 excvaddr=0x40000000 depc=0x00000000
[19:43:25]ctx: cont
[19:43:25]sp: 3ffffcc0 end: 3fffffc0 offset: 01a0
[19:43:25]3ffffe60: 400005e1 00000000 00000000 fffffffe
[19:43:25]3ffffe70: 4023139a 00000030 00000010 3fff0dc8
[19:43:25]3ffffe80: 4021f6fe 2d44454c 3ffea4e0 000000ff
[19:43:25]3ffffe90: 0000ff00 00000000 40404040 00000000
[19:43:25]3ffffea0: 61644100 00000003 3ffea7f4 3fff1ca4
[19:43:25]3ffffeb0: 3fff1e60 3fffdad0 3fff1fac 00000000
[19:43:25]3ffffec0: ffffffff 3fffc6fc 00000001 3fff0dc8
[19:43:25]3ffffed0: 00000000 3fffdad0 3fff1fac 00000030
[19:43:25]3ffffee0: 00000000 000045ff 00000000 3fff1f6c
[19:43:25]3ffffef0: 00000000 4bc6a7f0 09374bc6 00000000
[19:43:25]3fffff00: 00000000 00000000 4bc6a7f0 00000000
[19:43:25]3fffff10: 00000000 4bc6a7f0 40100b38 00011d31
[19:43:25]3fffff20: 00000000 3fff0dc8 00000000 00000003
[19:43:25]3fffff30: 0149c0b2 3fff2a1c 00000000 00000003
[19:43:25]3fffff40: 3fff5114 40223acc 40100b38 3fff1ae7
[19:43:25]3fffff50: 3fff1aed 00000000 3fff0dc8 4021d1f7
[19:43:25]3fffff60: 00000000 b2f2b18d 3fff0d00 3fff1fac
[19:43:25]3fffff70: 00000000 00000000 3fff0dc8 3fff1fac
[19:43:25]3fffff80: 3fffdad0 00000000 3fff0dc8 4021d2d0
[19:43:25]3fffff90: 3fffdad0 00000000 3fff1f6c 4021dc10
[19:43:25]3fffffa0: feefeffe feefeffe feefeffe 40233b08
[19:43:25]3fffffb0: feefeffe feefeffe 3ffe8800 401008a5
[19:43:25] ets Jan 8 2013,rst cause:2, boot mode:(3,6)
[19:43:25]load 0x4010f000, len 1392, room 16
[19:43:25]tail 0
[19:43:25]chksum 0xd0
[19:43:25]csum 0xd0

Thanks everyone.