Can't connect to web interface after WLED have joined to router

Flashed an ESP-01 512k with release 0.10.02 and everything works fine when WLED is in AP mode, but in the client mode doesn’t. I see in the devices list of my router that WLED get an IP and connect to network but can’t connect to it with my browser… I’ve tried to reflash after total erasing in esptool unfortunately it did not help…

You’ll need to know the ip address of the ESP that your router assigned to it to log in after your initial config to the wifi network. I assign static ip addresses to all my NodeMCUs through the wled wifi config. Also, I make it so that the “AP opens” is set to always so that I can get to it directly as a wifi connection regardless if it is connected to the router or not. Just a suggestion.

Thanks for the advice. Yes I have the ip that assigned to my ESP, also tried to assign some static address. Nothing changed. After that WLED is not available in my home net and as AP too.

If you reflash wled onto your controller and make sure you have ap set to always available, you should be able to still find it as a wifi network in your home. Connect to it and it should automatically take you to the device page in your browser. Check the “info” button and see what kind of signal it has. Maybe you need to move it closer to your router? After that, I’m out of suggestions for now and will leave it to someone else to offer advice. Cheers.


Given you say that you can identify that your router has given your WLED a valid IP and that the WLED works in AP mode it’s save to assume that the software and hardware works.

That leaves your network. May I ask if you are trying to connect to your WLED’s AP with another device that is on the same SSID?

Yes the same network the same router. In AP mode it works only until I enter the password of my router.

I tried to make it always available and now WLED AP is appeared in the list of devices but I can’t connect to it


Are you trying to connect to your WiFi WLED with another WiFi device connected to the same SSID?

Trying with my laptop connected to the same SSID


If possible connect to your laptop with a wire to your router and see if you can’t access your WiFi WLED.
If you can then log onto your routers administrative interface and look in the WiFi/SSID configuration section. Look for a setting similar to “SSID client isolation” if you see such a setting then disable it if it’s enabled. You may need to reboot/restart thing after making this change and or course saving changes.


As far as I know the WLED software doesn’t ask for a password.

Default password is wled1234 if memory serves. Only need it if asked. I never have, but I do set a password immediately after allowing access to the AP “always”. Click save and reboot.

I mean login and password of my SSID in the WIFI settings of WLED software.

So after you flash the WLED AP show up. You can connect to it with your WiFi laptop and enter your WiFi SSID and password? Yes?

Then you restart the WLED and you can see that your router assigned it a local IP address? Yes?

Then you try to connect to the local WiFi local IP with your WiFi laptop? Yes?

At this point you can’t connect? Yes?

Everything is absolutely correct besides I can use WLED while it in AP mode. One more thing when I enter my SSID and password and save changes the blue led on the ESP 01 start blinking.

Okay. With the WLED blinking it’s blue light. How do you try to connect your browser back to the WLED?
What is the URL/Address you use when trying to connect at this point?

The ip that the router assigned to WLED. Also tried to set static ip.

So in your browsers address bar you have “http://nnn.nnn.nnn.nnn” where the n’s represent the IP number in your routers DHCP assignment log for the WLED?

Only ip without http://


I don’t know what to say at this point. I do know that you are not alone. I myself have had problems getting a ESP32 to work. Same symptoms as you. My only suggestions now is you get on the WLED Github and add your name to one of the several “Can’t connect” reports.

If you have another brand of board give that a go.

Sorry I couldn’t help.

One final thing. Open up a command prompt or terminal window on your laptop and see if you can ping that IP address.

ping nnn.nnn.nnn.nnn