Can't get Athom ESP32 to work


I think I’m missing something obvious, still no clue what it is but WLED isn’t working.
I have an Athom ESP32
not because of the music but I prefer ESP32 above ESP8266
Then I connected an " SK6812 Rgbw Led Strip" 5meter, 30 leds a meter = 150 leds
and a 12V 2A 24W power supply.
Now I only want to test 30 leds, so I assume this would be enough.

But no matter what I try WLED isn’t working, it’s always the same
the first 16 leds are off, then 6 leds are burning real soft white blue. and somewhere in the middle 1 led burns full bright white.

I can’t even get everything solid the same color.

Even when I Disconnect the datacable form Dat1, it’s still the same result. It almost looks like data isn’t transmitted.

I just did a factory reset, set wifi and ledstrip again, but still no difference.

Does anyone know what I’m missing here?

Are your LEDs 12V devices?
Can you communicate with the WLED GUI?
Do you have a levelshifter?

Have you tried connecting your strip to a different GPIO (and update the WLED config)?

Hey, I was facing quite same issue some time ago and I Also tried everything and nothing seemed helping til I came up to this:

At fist try asking Athom for the firmware (Digital music 2 channel Controller ESP32) and install it!
You can do it on the interface or directly via serial.
For This on this other hand you will need a USB to TTl converter in order to actually getting data on it.
Lucky the needed pins are already labeled on the PCB of the controller

If that doesn’t fix that problem:
Download the latest or needed version from this
GitHub Wled installation side, it should look like this:

This ARE usually includes the Sound reactive Version with 4MB flash , if not needed then use just ESP32.bin with 4MB flash instead.

Please only use the 4MB flash versions otherwise the controller may inaccessible with interface.
If this happens for any reason you will need to wire Flash it (TTL) !

Pin assignment if needed after flashing:
Button(GPIO0) - Standard




Hope that will help

Sounds the string is faulty

Sorry for the late response,
my response notification ended up in the spam.

I did the update, don’t really need the music part, so without the ARE part, but that didn’t help.
I also tried connecting ot DATA2(GPIO17) but that doesn’t make any difference,
I actually don’t know what DCLK is, so I leave that part alone,
I don’t know where to connect it to anyway, maybe it’s for different kind of ledstrips.

So I actually think maybe my ledstring is broken llike @TheLight3r mentions,
I don’t know for sure, I have to order a new one to be sure.

1 Like

I can confirm,
I just received my new led string and it works immediately,
maybe I overheated the first one, Or it was already faulty to begin with.
no idea.

If you still have the first one and are not sending it back, try cutting off the first pixel and see if it works from the 2nd pixel.