Corruption in backup file presets.json

Using DIg-Quad-ESP32, WLED 13.1, WIFI connection, and Firefox. Laptop and ESP32 separated by about 6 feet. I have about 20 presets. All presets display as expected when selected in WLED.

Used WLED->Config to create a backup of my presets. Noticed that presets.json has some sections containing 20-30 spaces when viewed with an editor or online json formatter.. Also noticed the presets where the spaces occur are incomplete. Made a second preset.json backup and the two files have no differences.

Have not tried to load the presets.json file into WLED over concern of preset corruption as reported in another thread. Backup cfg.json looks ok.

I am currently unable to attach the presets.json file due to my new user status.

EDIT: Appologies. After a more thorough examination of the file, all preset data is present and accurate. The extra spaces has just caused the data to be reordered a bit. Assume the extra space data will be ignored when the the file is used in a restore operation.

You can visit discord to post files WLED


I have seen this issue as well. I even tried removing all presets and starting over. As soon as I create a backup, the whole presets are corrupted and won’t load properly

Try 0.14 beta. It has an attempt to mitigate corruption.

Having the same problem. So frustrating! Where did you find the 0.14 beta? I have searched everywhere and can’t find it!

build your own from source or check @srg74 Github repository

I’ve been seeing this regularly as well, with latest git from a few days ago. Pulled latest today and had the same thing. I don’t normally make a backup, but I have been using the /edit endpoint to copy the json out to a text editor (manual backup).

No changes wit the updates to json.cpp and presets.cpp submitted this morning. First attempt to push a change to Preset 51 caused the corruption. (This was done via the UI.)