Digiquad trouble can't get 4 channels to work with WLED

Hi I’ve got a Digiquad that i’m trying to run 1200 ws2812b led Lights off of, I’ve got it set to where the first channel is 300, 2nd it 300, 3rd is 120, and 4th 480, figuring if it only does 300 per channel then im ok if all 480 dont light up. they are 12v leds and i’m running all the power I’ve go the external power source running all the power through the Digiquad. when i turned on the Digiquad the 1st to channels powered up right away. i then brought up the WLED and connected through the directly and not through my wifi. i went to configure the lights and using the 12.0 WLED software on the configure tab im confronted with the hardware set up tabs (which kind of resemble the segment tabs that i watched the video about). I watched a new video about configuring the hardware tabs and i thought i did this correctly but i cant get the 3rd channel to light up. led 1=pin 16. led 2= pin 3, led 3= pin 1, led 4= pin 26 (according to video). I noticed on the Digiquad Board itself It’s written that LED 4= Pin 4, so i tried pin 4 instead of 26 it yielded the same results, and I also noticed somewhere that LED 2 and LED3 was reversed so I changed those pins as well and although the started flashing different colors and sequences that i never chose i still was able to change them and control them so it worked as well. All the different ways i chose to route the pins and they all worked except led 3 still did not. in all the scenarios i’ve listed above everything worked and i had had control over all LED channels except 3.

I then thought maybe i needed to add power because i was trying to run 1200 leds maybe i needed more power so i injected power before and after the led channel 3 and nothing no change at all ( I injected the power through the digiquad and not an external power source directly (when i injected the power from an external power source directly the leds lit up the generic color they do when they are not assigned, but i was still not able to change them or control them in any way, so i thought maybe i need to inject the power through the digiquad that way i will be able to control them, when i hooked them up to the power supply though the digiquad they didn’t light up and i went right back to my original problem of them not being able to light up at all.

I’m starting to think it is the amt of lights im trying to run, I don’t know if it is not able to handle that many lights, but it says it is so i don’t know what i’m doing wrong. I’m thinking maybe its a box i’m not checking or something very simple because i feel like ive follow the directions well or pretty well and I’m missing something.

I also thought maybe its the digiquad, maybe i have an issue on mine with LED 3 channel, but i have 2 digiquads so i tried the other one and exactly the same issue, so I really think i’m missing something. and as far as boxes, I have ENABLED automatic brightness limiter because all of my leds are 12v and so is the power supply and when you check that box it says it runs it through 5v and i didn’t want to fry anything. setting up my hardware. i input the numbers like this. LED 1 0 300. LED 2- 300 to 300. LED 3 600 to 120. LED 4 720 to 480. because it it says start and the count. i started at 0 teh count was 300. i started at 300 the count was 300. I started at 600 the count was 120 and i started at 720 the count was 480. i’m grasping at straws here now. can you think of something im missing?

I know this is long but i wanted to give you as much info as possible. thanks for any help

Hi! Pins 16, 2, 3 and 4 are indeed the correct pins for the v2 version of the Dig-Quad (v1 had 26)
16, 1, 3, 4 are the correct ones.

Can you try swapping the data wires of LED 2 and LED 3 in the Dig-Quad terminal? If afterwards LED2 is not working, it is an issue with your wiring or LEDs, if LED3 is still the one broken, it is a software or Dig-Quad problem.

Are you sure it is 2?
My setup uses 16, 1, 3 and 4.

This is correct setup for Dig-Quad v2.

You should swap pins for outputs 2 & 3 on production version of Dig-Quad.

1 Like

You are 100% correct. 16, 3, 1, 4 are the pins we need. It always confuses me that the pin that is gpio 2 on 8266 is gpio 16 on esp8266

thanks everyone, I really appreciate all the help, you guy really are the best, Everytime i come across a problem this board always comes to the rescue!! thanks again !!

1 Like