Domestic Automation controller w/ WLED

Hi all, same as many of you I’m a big fan of Chris Maher’s work. His recommendation of Domestic Automation’s controller’s captured my interest and I bought one but I can’t get it working. I love the higher quality vs. the Athom controllers I have been using with WLED preflashed. I have used all different kinds of lightstrips and configured them all just fine but this one is different and there is no documentation. I purchased their new controller for sk6812’s and I can’t get the 3 primary colors all at once. I’ve been playing with the various RGB/RBG/BGR/etc. settings and can’t find one to support all 3 colors. I’m getting mostly red’s and blue’s but sometimes green’s. There was a card in the package that is very vague and references “Relay GPIO 12” and a checked “invert” box. On the back of the card are more config settings but they don’t make any sense and there is no explanation. This makes no sense to me as I’ve never had to adjust these settings with the Athom controllers.

While we are at it can someone explain why this 6812 controller is different than their base model which run’s all of the 28xx strips? The Athom’s with WLED ran all strips and did not need a separate model for 6812 (yes I know 6812 has a white chip but so does Athom). Also, the Athom’s didn’t need any config changes to the GPIO settings.

Whether you purchased from Amazon or not, got to Amazon like you’re going to buy it. There will be photos and one video that show up after you pick the version you bought here or somewhere else. Watch the video.

Just make sure to pick the version of controller you have from the list, but don’t buy it, you just want to watch the correct video.

Just connect your LEDs to the attached three-color tail. Then plug in your power supply. Start your programming using WLED. Follow the video.

Review Chris’s YouTube video, that is helpful too.

One other comment, the color of thr LEDs on the controller board, may not match your strip of LEDs. For example - set your strip using the RGB GRB, etc using WLED. The LEDs on the controller board my not match. Red on the strip maybe green on the board. No big deal.

Directing me to videos is the laziest form of support. You just wasted my time watching the video you directed me to as it has no configuration support and appears focused on how to set up the stupid button that can be added to your board. I don’t need buttons or PIR sensors on my WLED board as I can get those in the normal smart home avenue. I have configured a dozen different Athom controllers with WLED on all various types of strip lights. I cannot configure your controller on WLED with my 6812s. You have no documentation and if you’re not going to provide any, I’ll simply return this and go back to the Athom controllers.

You’re right. I’m a lazy, visual learner. The controller board has three things requiring your action. There are two outputs on the board delineated by rectangles drawn on the board. One output has a three color “tail” to which you may hook your LED strip being aware of the colors for power, ground and data. If you can’t use the “tail”, inside the other rectangle is a wiring terminal, again with plus, minus and data. Note inside each rectangle is a GPIO PIN number. You use that number in WLED programming. Which you indicate you’re very familiar with. The third connection is that silver cube into which you plug in your matching 5volt power supply.

If you are using two LED strips, you would use the connections in both rectangles. The “tail” and the plastic terminal. You would need both GPIO PIN numbers in WLED programming.

Good luck.

(The board is from Domestic Automation, LLC, fortunately in this case, not mine)

I am not looking for any connection help. It’s pretty easy to take my 6812 tape and connect it directly into the connector clip coming out of your board and I already had a 5v power supply with a barrel plug that plugs nicely into it. So you spent a lot of time telling me how to physically hook up something that I did not indicate I needed help with. What is different about your set up than all of the Athom controllers I have used is the config. I’ve never had to indicate which GPIO pin on an Athom controller. They just work. When I’ve had problems with the RGB designation I’ve been able to play with the different settings in the configuration. However, that is not working on your board. I have 6812 144/m 3m strips from BTF. Pretty standard.

Is your strip RGB or RGBW?

The difference will need to be known by WLED while telling it which GPIO PIN.

There are 6 RGB color combinations, a potential 4 white SWAPS.

This is an example, full of errors, but kind of an example

Of course my 6812s have a pure white as that’s what makes them distinct. Using GPI0 2 in the 1st output finally got my lights up and going however the very last LED pops up as pink only for the green and white settings. But it doesn’t do that on red or blue? Also, I don’t know why there are 3 lights on the board. There’s a tiny blue one where one of the chipset receptacles is and then I have two green LEDs on the board. There’s no explanation as to what they are or how to turn them off. The second strip of 6812 that I plugged into my first strip serially will not come on at all. I have swapped the two strips, and yet the first strip works and the second one does not. In the config I followed your advice on setting GPIO to 1 for the second output. I tried to play with that and set it at 2 but it would not accept any other setting other than 1. So the series run of the 2nd strip doesn’t work.

I appreciate your individualized support but I would recommend issuing documentation. I can’t imagine you will have time to support your product individually if it becomes as popular as I hope it becomes because I want you to succeed.


I’ve reached the end of my knowledge for this board. I don’t work for or have a connection with Domestic Automation. I might suggest contacting Chris through his web page or perhaps someone here will respond.

One thought about LEDs on the board; one is possibly power, the next is the first LED of a strip, and the other is the first LED of the other strip. You can turn the first LEDs off via WLED programming. The knowledge base can explain it.

Good luck with your project

Spending a lil time reading the q/a @ amazon for those boards…

Like LowOverhead said: 1 LED is Power, 1 is the first LED for port 1 and the 3rd LED is the first LED for port 2. They have basically added those 2 LEDs on those boards to act as a crude level shifter/data booster to take the 3.3v logic of the Esp and boost it to the 5v data that LEDs look for.

  • I personally think that is a crazy way to design a product that is being offered for sale. If/when those onboard LEDs die your controller is useless. Why not include a proper level shifter…

  • It also messes with your LED count (unless you check the box skipping the first LED). This is likely why your last LED was not working. Did you put in your LED total plus 1 for that onboard LED?

  • This crazy design (onboard LED) is also why they have to offer different controllers for WS281x and SK6812

In LED Preferences you have to make sure the relay is set to GPIO 12 and inverted box checked (like your little card said). This sets the GPIO for the onboard relay and inverted box is for how the specific relay operates.

The port with the screw terminals uses GPIO 1
The port with the pigtail uses GPIO 2

The RGB color order and White swap I would think would be set the same as your other Athom controllers as that is more to do with the manufacturing of the LEDs than your controller. (That onboard LED may not behave the same as your strip depending on whatever the manufacture used for it’s color order). So likely you just need to play with the color order/white swap settings till you get the correct combination (look at your strip not the onboard LED).

When connecting a second strip to the first strip make sure you remember to increase the total LED count in LED Preferences and also check your segments from the main GUI window for the correct number of LEDS. Also when adding a second 5v strip after the first one, you will likely need power injection as you can not expect the power to carry that far being only powered from the beginning.

My apologies to low overhead as I was receiving your emails thinking you were the seller of this board. I didn’t realize we were posting back-and-forth as I am new to Discord. Thank you for your help and I apologize if I came across as being short with you.

Jinx - you are a wealth of knowledge. Thank you for those explanations that all makes sense.

do you have the link for what you bought?

(Please note I’m in USA)

Search for Domestic Automation

I have not used these with LEDs yet. However, I’ve been running controller on my desk for 24 hrs per day for a week looking for problems before installing. I’ve seen none. Connecting it up may or may not be different.

I have to laugh at their listing:

“OPEN SOURCE SOFTWARE: The LED controller comes preloaded with open source “WLED” (white light emitting diode) software.”

Actually ‘WLED’ is: WiFi Lighting Effects Driver


Just got my first DA Wled controller and I may have broken it. Everything worked fine for several weeks, but then I had a random RED pixel that would start at p#0 and slowly move up to p#25. I was trying to configure the board for E1.31 comms when this first happened, then later in the day all the WS2812b strip leds went off. The onboard led still changed colors on demand. I did a reset and still no LEDs would turn on - then several more factory resets. I checked continuity of both fuses and they were good. The controller sits on my desk in its little gray mounting bracket. I’m not sure what else to check.

I blew a fuse, replaced it and it’s been running with a short strip 8 hours per day, for a month without any problems. No help for you, sorry.

Hello! I have a Domestic Automation WLED controller and i just recently tried to upgrade it to 14.2. Something happened and now WLED says it is offline. I tried connecting to the local WLED-AP but it is not broadcasting and the board is not connecting to my WiFi network, This board does not have a usb port on it so I can’t try to re-flash it. Any ideas?

This video really does not show much. Can you please provide more detail?

What you should do is something like this :
ESP 3.3V —> VCC programmer (3.3 V)
ESP GND —> GND programmer
ESP TX —> RX programmer
ESP RX —> TX programmer
Also connect gpio0 on your ESP to GND prior to connecting the programmer
to your PC and it should flash . Some examples on YT like below so might be
could guide you further

Sorry to inform you but you lost your money because the Company is gonna tell you to turn on & off Six times and leave on the seventh time and it’s supposed to fix it !!B.S I have lost $90 on two boards and can’t get any help from Company!Go back to the $5 esp8266 board it does the same exact functions!Good Luck