ESP32 C3 Supermini Crash and Lost Functionality

Hi there, me again. C3supermini journey part 3

I had everything working so profoundly well; C3Mini SR with INMP44 and 160px cob WS2812 strip. Defined all pins in the preferences, even had a pushbutton configured. The only weird bit was when wiring the mic, wiring L/R to GND had no effect. So as a last ditch effort tried routing it to the other board pins, and miraculously it worked when routed to GPIO 21. So i soldered it and didnt question further. :nerd_face:

But then, tragedy struck. As i was taking videos to show off the build, I had what i can only describe as a crash. This happened without any movement of the setup, it was completely stationary. The strip turned off, the powerbank it was attached to abruptly shut off too which it usually doesnt do when unplugging a device from it. Then after replugging the setup i was confronted with strange problems:

  • The mic stopped working, or at least, WLED stopped being able to pick up sound from it
  • The LEDs only lit the first 60 (later found out that i could shift which 60 leds were lit by using the “skip first” box in the preferences, and could get less than 60 to light, but not more than 60)

As of now i’ve fixed the led limit by reflashing (side note did you know WLED can recover your preset list after reflashing even though the device gets [apparently] wiped clean? neato!) but still cannot get my mic to pick up any sound. :frowning_face:

Whats the deal internet? Has anyone had a similar issue with the strip not lighting what it’s supposed to? Do we think my mic is toast? Luckily i have another one so i’ll probably try wiring in that one instead and see if that works, but 6 is just so many wires to solder for one digital mic and i need a break :stuck_out_tongue_winking_eye: