ESP8266 and TTP223B touch switch

Hello dear friends, I would like to ask you . How can I use the touch button and the WLED firmware to switch effects with a simple tap in my case, this is TTP223B ?

See the wiki - Macros & Button.

Forgive me, you probably misunderstood my question, ttp223 has outputs of the VDC GND and a control output, if the control output is put on output D3, then the esp8266 loading does not work at all. This is not an ordinary button that closes 2 contacts, it raises a high or low signal at the output.

I solderd Jumper A and attached it to Pin 4 (ESP32) GND and VCC to the power souce (5V max)
In the newest Version of WLED you can change the pins for buttons -


You can use the touch just as a regular button now… only problem is that darn red LED of the Touch

Thank you you’re the best . The problem with the red LED is solved , solder it out or damage it ) and on pin 4, the ESP8266 did not want to work . I used pin 5 in the settings this is D1 and everything worked

Hi, Trying the same config
Wemos D1 mini
TTP223B - D1 pin
Config - Button PIN 5, Active Hight
but it not work…
Firmware used - 0.12.0, 0.12.1b1

Firmware 0.12.0 you need to close contact A on the touch sensor TTP233 as shown above in the figure < thorn > . in the sync settings, the check mark should also be

Yes, I forgot it, but when I check “push button” or others there is no changes, it not work and also after reboot it resets.

This is probably a problem with the firmware try using or on 2MB of memory apparently your internal memory does not work and flash the Bin files and do not collect them yourself

Thx for help, but same problem.

I found this:

  1. Pushbutton checkbox resets after reboot (tried firmware 12.0 1M and 12.1b1)
  2. I’m using macro presets, if pushbutton configured for - default 0, long press 2, double 1, it has problems, but if i will configure all to 0 it will on/off only with double press. Any way pushbutton checkbox will be reset after reboot

Note: Previously I used same hardware with custom 11 firmware with custom touchbutton user addon (highstate and gpio5) and it worked.