‘Glitch’ with moving effects - v0.10.0

I recently installed led strip lighting on my house - obviously using WLED and I am getting nothing but compliments. Thanks Aircookie for all the hard work!

Ive noticed with my recent install that I am getting a pause or delay with ‘moving’ effects. On meteor or scan for example, the LEDs will move and then abruptly pause for a split second, then carryon where they should be.

From what I can tell It’s not always in the same place (it doesn’t appear to be consistent nodes on the strip), the location of the glitch or delay seems to vary based on the effect (chase, loading, meteor).

If anyone has any ideas I would be extremely grateful.

I have approx 1600 LEDs fed from 2 x 70A PS and currently using 2 x esp8266 with logic shifter to control the two zones. Voltage drop isn’t an issue, and connectivity seems to be ok, I seem to average 56% to 64% currently. Running v0.10.

I’ve tried flashing/rebooting the esp several times, and playing with different settings in the app but can’t seem to figure it out. Any help or ideas would be appreciated.

Do both esp units do it? And if so are they configured to sync with each other?

My thought would be that when servicing Wifi to sync there is a delay in the light output. Just a thought but guessing on setup.

Each esp is doing the ‘glitch’. They are syncd together, so that may be an issue. I did a quick check this morning before work, and with the sync off I still noticed the glitch on he front bottom lights.

Below is a picture of my set up.


I have 4 ‘zones’ on the front of the house (each fed from its own esp). I haven’t soldered up 2 esps, currently am using 1 esp to feed 2 zones. (The dotted line on my drawing is my jumper after the logic converter to put the data signal in parrallel).

1 also have 1 esp for leds on my deck railing. When the deck railing is syncd to the front it does glitch. Ill have to confirm when its on its own esp.

My thought was that the 4 esp would give me more flexibility for the front lighting, but maybe it’s over complicated.

I’ll check tonight with each zone using its own esp and play with it a little and see if I can find anything.

It’s a fairly high pixel count across just two controllers so perhaps you are dropping a few frames at certain times within a sequence. This would certainly explain the slight judder you are experiencing. I believe 500 pixels per controller is the recommended amount for smooth transitions and good frame rates.

That seems possible- I am going to try and separate each ‘zone’ to one controller to keep the pixels under 500. My neighbor and I did a similar set up, same equipment. He has 2 controllers with approx 600 pixels each, and doesn’t have any issues with a lag or glitch.

It confuses me because the glitch, or lag, seems to appear after the transition, and at different pixel locations (pending on the effect being used). My primitive understanding is that the controller sends a signal to pixel #1 and it gets repeated to the next pixel. So The signal transitions ok to communicate the new effect, but consistently misses communicating at a group of pixels pending the effect. The lag happens on every cycle of the effect across the strip.

Are you using a temp sensor, MQTT, HA or some other interface?
Network operations could cause this glitch where the LEDs are not updated for a moment because the ESP is busy dealing with the request.

Awesome setup by the way! Looks dope!

1 Like

Not that I am aware of. I actually soldered up two new esp8266 yesterday, flashed them with 10.2 and installed them last night. Other than changing the led count and removing the brightness limiter, I am not adding anything. Is there something I could disable/enable that might help?

With different cards, and 10.2 I am still getting the same result- that gltich or lag. I made some better videos to show what is happening using different colors on the zones.

Watching the effect cycle, the glitch seems to start at a location, and then each cycle, move ‘back’ on the strip with each pass. I played with changing the led count (up & down) and that didn’t seem to make a difference.

Thank you for the good video! Actually what matters is not the location of the effect when the stutter happens, but rather the interval between stutters (it is not an issue with the effect function but with the controller being busy with networking and thus not being able to refresh the LEDs for a second).

From the video I’ve determined that the interval between each stutter is 10 or 11 seconds.
The only WLED interfaces that use that refresh rate are the NTP time and Blynk service.
You can make sure those are disabled (even though they should be by default) by making sure the Device Auth token in the Blynk section of Sync settings is empty (if it says “Hidden” delete that and save) and that Get time from NTP server is disabled in Time settings.
Hope one of these are the culprit as i have no other explanation :slight_smile:

That is great insight - thank you! I’ll try it tonight.

I know that the NTP function is currently enabled on all my esp controllers. (which is another issue that I am having trouble with- I can’t get the time in the app to sync to NTP to utilize the macros. I have a question open up that I am working through as well).

I will take a look at ensuring the BLYNK and NTP is disabled tonight and follow up.

1 Like

Ah ok - in that case the NTP is indeed the culprit. This behavior happens if it tries to obtain the time but fails every time - because the NTP server is not accessible for some reason (e.g. if the ESP is in a WiFi network without Internet access). If your ESPs do have internet access, it might be a problem with your ISPs DNS server, and directly inputting the IP of an NTP server (preferably in your area/continent) could help.

Disabling the ‘Get Time from NTP Server’ definitely worked. Thanks for all your help @Aircoookie getting that fixed. The App and support from yourself and others on this site are second to none!

The ESPs do have internet access. I’ll work with my ISP to see if they have any insights.

Thanks again!

Try setting NTP server as your home router, or some PC or network device that’s always on and have time services enabled.