Glitchy - help

So I have a 60amp power supply, dig quad running 3 strips of SK6812s (at the moment have about 11 total I want to string), 16 gauge stranded copper wire. I set everything up and it tested fine (including a 50 foot run of power/data cable before the first LED). Ran the cords through the attic, installed the channel, and put strips up. Power injection running parallel start and end of each strip. Now, all colors/effects are glitchy to varying degrees. But it’s pretty bad. I double checked all my connections and everything seems good. Using ferrules at board and solder seals at every connection. I removed the plugs from strips since they are outside, and solder sealed all connections. I do have one corner that I have cut and soldered a connection to the pads on the strip, but tested fine in garage.

In playing with the settings, when I check the “use gamma correction for brightness (not recomended)” box - it helps alot, like only a few random blinks when changing effects. But with this box checked the colors on alot of the effects are wrong and shift.

The white channel of the sk6812s seems to work great. All the effects work as they should when it is just white. The heaviest glitches seem to come on a multi color effect like something rainbow, but some work OK with the gamma correction for brightness checked.

Here are my settings:

I ran two sets of wire through the attic, one to go one direction, the other to go the opposite. I thought I would try to use the other cable to rule out a wire issue. So I set the other cable to the second data pin on dig quad, went to light up a strip, and nothing. Strip and wire getting hot though (nothing else is even above ambient). I quickly unplugged the strip and shut everything down for the night.

Any ideas what could be causing the glitches? Thank you.

A possibly easy thing to check is the series resistor on the Dig you have. Sometimes the value needs to be lower than what was used on the board. Short-out a resistor (wire across it) and see if that fixes it.

If that doesn’t work, look into another method for the data signal. Something like an RS485 transceiver or Quindor’s data booster.

Hi Tony, great, reading about that, seems to probably make sense that might be the issue. I will order a data booster from quindor but it will take some time to get here. I am no expert with small electronics by any means. When you say short out a resistor by wiring across it…can you explain a little more? I see “LED1” “LED2” “LED3” and “LED4” on the back of the board, all with 249

Depending on the length of the wires from the data pin in the dig-quad to the start of each strip, the optimum value for those 4 resistors changes. There are 2 generic values / situations, 33 Ω and 249 Ω, and near and far.

If the brightness is lowered and the problems go away, it’s power injection. If the brightness has no real effect, it may be that resistor value.

When you tested everything out in the garage or yard or somewhere you could wire it up before installing, did everything work correct at all brightness levels? (On my first test, I had LEDs strung all around my living room so I could see how things worked)

Everything did work correct at all brightness levels when I was testing in my garage. Had 4 strips set up. I had a 50 foot piece of cable spooled on the floor between the dig quad and the first strip of LED’s just to test, and it worked great, but not when I strung the wire through the attic.

Lowering the brightness has no effect on the problems, and my cables are three wire in one casing and long, so I am pretty sure the resistor value is the place to start.

I ordered a data booster but it will take some time to get. So I guess I am going to try and short out the resistor if I can figure that out.

Take a look at using an RS485 TX-Rx pair.
Cheaper than a booster and designed for very long (75m or more) data runs.
Probably find on Amazon now like:

You use heavier gauge wire for power and simple Cat5e or 22/4 wire for data, just connect the grounds.
Much easier to keep everything neat IMHO.

A very stupid simple way to short out a resistor is with a delicate hand, some electrical tape to protect surrounding circuits and components, and a flat blade screwdriver of the proper width to bridge right across the tiny resistor.

That tiny screwdriver might be called a “tweaker” to certain electronics types of a certain age that had to tune analog circuits (aka, tweak). However, a real tweaker was often made of plastic so it would not interfere with the electromagnetics of the circuitry while adjusting…

Back to the point… Liberally apply electrical (not duct or other static creating) tape so the only thing visible is the 3 resistors. Have someone look at the lights as you one at a time (maybe via phone or rf radio – walkie-talkie) tell you what they see while you short out the resistors. If shorting out a resistor solves the problem for all 3 strips, you can power the dig-quad and get 3 blobs of solder to bridge across the 3 resistors, shorting them out permanently.

@Quindor recently posted a YT video where he showed a couple methods of handling this same situation in case you are unsure about it.

If the data wire is bundled with the power and ground wires for the LED strips, it can introduce noise which causes the LEDs to get bad commands which make them look “confused”.

As a simple test, you can run a separate single wire from a Dig-Quad data pin to the data in pin for an LED strip’s first LED. If that suddenly fixes the problem, your 3-wire cable is introducing noise by the way it is built.

For example, there are ways to use cat 6 cable to power LEDs that can introduce noise, and there are ways to use the same exact cable that might cancel out the noise. FYI, I do not recommend using any type of computer network cable (cat5e / cat6 or higher).

One last thing to consider is the route the wiring takes. The path the wiring takes can introduce noise. If it is parallel and near existing house AC wiring, noise can be generated into the LED strip data signal. The closer the wiring, the worse it can be.

It might not show up until something on the circuit is powered on and running. Like if there is an attic fan, when the fan is off, the data signal will be unaffected if the LED cable is tied to the attic fan power cable. But, once the fan turns on, it might introduce random noise into the data signal and corrupt the LED display.

Please post your results when you find something that helps.

1 Like

Depends on how you use it (as you mentioned).
If you simply connect the wires from a GPIO output dirctly to a strip, I agree completely.
You’re probably adding more noise than not.
If you use that cabling with the type of circuit it was designed for - a RS485 Tx-Rx pair - you will get a huge improvement in noise reduction.

Unsheilded Twisted Pair (UTP) cabling like Cat5e/Cat6/etc. cabling was designed specifically for that usage. It works very well for data transmission, that’s why most networks you run into make use of it.

OK so, I ran two 16/3 wires in the attic, one for a segment to go left, another for a segment to go right. I just used one wire from one cable for data, and power wires from another, separating the power and data signals, and the problems are gone. So I guess I need to run another wire through the attic and have two for power and one for data and I should be good. I guess I should have thought about that from the start. Thank you all very much, I would have looked at this for days and never thought about noise in the data line from the power.


So glad you found a solution and things are happy without any soldering :slight_smile:

There was a recent video from The Hookup that went through shorting out the resistors.

OK, so in addition to this project taking way WAY longer than I expected, the glitch is back. I got to my second section, output 2, and when i turn it on, the glitch is back. I can set up segments, and as soon as I go one light crossing into both outputs, the glitch is back. Both outputs run fine when alone, but any mixing of them, and glitch city. Worse glitch than before. I must have a setting wrong, anyone know where to start? I am probably missing something about setting up two outputs. I tried LED2 on GPIO 3, and LED3 on GPIO 1 - same on both.

something else strange that is happening: WLED keeps freezing, and resetting to what appears to be factory default. At least, it removes all my outputs and replaces them with a single 30 light WS281x

Resets back to “default” 30 lights are usually a sign of a power issue (short somewhere taking out the power bus?)
Or a bad flash or bad MCU (probably not with a Digi board though).

I can see a strip getting hot if it’s on Bright/White for a while, but the wire leading to it SHOULD NOT.
Maaaaybe it would get a little warm, but if it’s getting hot, that’s a sure sign you’re wasting power in the wire due to a short or excessive voltage drop. That would be another thing pointing to a “power disruption” due to short, mis-wire, etc.

so nothing is getting hot anymore, after I rewired the second output. And the resetting to 30 lights is only happening while I am making changes to WLED. If it were a short causing it to reset, I would think it would be resetting on its own, not just while I was making changes to WLED? I also notice WLED changing number of lights on output by one. In other words, I put in 290 lights, and it changes it to 291, 292, 293, etc.

What version are you running?
Might be worth a reload from USB on the Web installer (not via OTA) to get a clean flash.
Get yourself up to V0.13.0-b6.
I also noticed you’ve got “Use Gamma correction for brightness: (not recommended)” turned on?
If you don’t know you need it, turn it off.

yeap I have 0.13.0-b6 running and i unchecked the gamma correction for brightness after I ran the new, separate data wires through attic.

Try make your changes with everything set to 50% brightness.
Just in case there’s a lurking power issue.

If the 2nd strip starts at 0, they will overlap and you will see glitching. I did some accidental overlapping on an earlier version of WLED where seg 0 had all the LEDs, and the rest of the segments were retaining their settings but were included in seg 0. It was very strange watching it run through the effect.

that is one of the things I thought about, the overlap by a few LEDs. But I have both outputs on a single segment, that is OK to do correct? I guess I will shorten both outputs by like 20 LED’s each and see if that makes things better. I did receive the quinn signal boosters, and put one on each data line, and it made a difference, but didn’t fix problem. With the signal boosters on and powered I can at least turn both outputs one single solid color now. But they blink every 30 seconds or so and its not stable, and I can’t do anything beyond a solid color. I did notice though with the boosters on, the chosen effect at least tries to go to both outputs. The glitch acts different across the different outputs, but without the signal boosters turned on, its just gibberish coming out of the lights - no semblance of whatever chosen. If that makes any sense.