Install.wled.me failed to open serial port

I am using Linux CentOs 7 to try to flash an KeeYees ESP8266 ESP-12E Development Board WiFi WLAN Wireless Module CP2102 for NodeMCU for ESP-12E for Arduino. When I click on Connect, I receive Failed to open serial port error message. I have the same problem with Linux Mint and Ubuntu. I can ONLY successfully flash the ESP8266 using a RPI4. The cable is not the problem since it works with RPI4. I am using a dual boot Lenovo Ideapad 110 which has Windows and CentOS installed to try to flash the ESP8266. Any suggestions would be greatly appreciated.
Thanx

Did you try on windows ? normally if you have the driver installed it should work but testing with multiple cables or even multiple MCUs could be a good idea if this is the first time you are flashing on that machine .
We have tried on ubuntu a while back and it worked but would really depend on your HW and it was not straight forward in our case due to the old hw we are using which is kinda buggy on Linux as you surly know and seen by now

1 Like

I would just boot into windows, install the CP2102 driver, reboot, and flash wled from install.wled.me

Thanx for the replies. Problem has been resolved. It was a Linux security issue. I had to add my username to the Dialout Group in order for me to successfully use the serial ports. Thanx again.