fails to open serial port

Hello! This is my first adventure into this space, and I seem to have hit a wall on step 1…

I have connected my ESP8266 to my computer and clicked install. My ESP8266 appears in the window. When I select it, I receive the following error:

“Failed to execute ‘open’ on ‘SerialPort’: Failed to open serial port.”

My online troubleshooting has gotten me nowhere. Any help getting past this error would be much appreciated! Thanks in advance!

You either don’t have the correct driver installed or are not using a data usb cable. Depending on what serial chip your board has on it, you would either need the ch340 driver or the CP210x driver

Reboot after installing the driver

@Jinx Thanks! Turns out it was my cable…

The installer is able to connect; however, the box popped up saying “Installing WLED Preparing Installation” but the blue circle just spins and spins.

I have removed and reinstalled the CP210x driver and tried multiple different cables but still get the same result… Any ideas?

This is resolved. Not sure what the issue was, but I was able to manually flash the chip using PlyFlasher. Everything appears to be working now. Thanks again for your help!

1 Like