Newbie Help - unresponsive controls & only some LEDS illuminate

I’ve got:
KeeYees ESP8622
WS2812B 60LEDs/m @ 5V (RGB / 3-wire)
Meanwell LRS-100-5 power supply
I’ve tried with WLED 0.12.0 ESP8622.bin and also WLED 0.13.0-b6 ESP8622.bin
I’ve double checked and my wiring is all good
When I power up I get only about one in every six or seven LEDs in no discernable pattern illuminate in greens and blues.

I can connect to WLED via wifi and power the ESP86222 on and off so as far as I can tell the board is working, however I have no control over the LEDs. The same LEDs stay illuminated in the same colours whether or not the ESP8622 is on or off. I can alter settings, presets etc in the GUI but nothing makes any changes to the LEDs.

I ‘think??’ I’ve got the settings close enough to get at least some kind of response. I cut the LED strip down to 36LEDs.
Max Current: 2160mA
5V 55mA max per LED
Colour order: GRB
GPIO pin: 2

Any suggestions on how I move past this problem?

Thanks in advance.

Do you realize GPIO2 in WLED is the pin labelled D4 on your board?
The other option is to use GPIO4 in WLED (labelled D2 on your board).

On this particular board GPIO2 is labelled D4 and it is located between D4 & 3V3 however I was suspicious about that and I tried both pins for data. Exact same results.