No connection to lights after update

I’ve Had 2 dig unos for about a month now, both worked great over christmas time. They have been sitting in my house, and i’ve been messing with the effects because it is all new to me. Only 100 nodes, attatched with a pigtail.
A few days ago, wanted to try and connect them in Xlights, when i did so, it said i needed to update my WLED version. So I did, by using the usb port. fallowed by doing the second uno right after the first. All seemed to go well, however after hooking them back up to the pixels, I get no output to the lights. the first thing i did was a clean install to 0.12.0. and then i disconnected and reconnected all the wires, checked the pixels with a tester, both orange lights are lighting up on the controller. This is the same thing happening with both of them. They are showing up on my WLED app, and i can also get into the controls by using the IP addresses. But like I said, the lights wont come on and it was a sudden change when i updated.

I’ve spent 2 days watching videos and reading trying to figure this out with no luck.
any help would be greatly appreciated!

What GPIO pin are you set to under Config->Led Preferences?
The default output pin may have changed from your previous version.
Being able to connect via the GUI is a good sign.

If you’ve managed to upgrade to V0.12 probably worthwhile to go up to V0.13-b6.
Bunch of bugs have been squished and many new goodies you’ll want to try.
Especially as you want to interface to Xlights.

Under hardware setup, led outputs… it says pin :2

My first update was to V0.13-b6, however when that didn’t work, I tried the other with the same results and then just started to research. It was just a big mistake to do both at once, but they were so easy when I first got them…

I got familiar with x lights, and then I was ready to add a controller n get familiar with that.

Do you know what physical pin on the Dig Uno your strip is attached to?

Very possible you just need to change that pin#

BTW how did you program the DIg Uno?

I’m not sure of the exact pin, this is all new to me.

I got both boards with wled pre installed. I pretty much just connected them to my network, change a few settings, and they ran the effects with no problem.

I did just try my second one again… and 16 of the 100 are lighting up, the 16h being red and the others all white. That one has V0.13-b6. And the pin says #1.

–Update 2019-09-18 + 2020-09-06

Two issues have come to light using the ESP32 Mini version

  • Using the ESP32 version the GPIO2 pin is connected to the onboard LED, the pin on the QuinLED-Dig-Uno with an ESP32 Selection 2 with the jumper is connected to GPIO16 instead!
    **** Next to this using an ESP32 also re-arranges the IO1 selection, this becomes GPIO3!***

–update 2019-11-13

  • There is a silkscreen misprint on the v2r5 version. The 3.3v and GND for Q4 and Q3 are switched. The actual order is 5v, GND, 3v3, Q4, Q3. This will be fixed in a later revision!

-Reading that it sounds like you need to set the pin in wled to 3 if you have an esp32 on it.

"Next to this using an ESP32 also re-arranges the IO1 selection, this becomes GPIO3!"

Thanks for the help! Both are working again!

1 Like