Nodes out of sync

I have 12 nodes (esp8266) up in the front a side windows of my house. Running B4. Only Alexa sync is on. I have 1 node set to sync (turned on) the rest sync to the one. Doing just simple presets, 10 sec at a time. They all work, most of the time. Sometimes one misses the sync change to the next preset, but gets it the next time the preset changes. Its not really the same node that misses, but some miss more than others. I’m getting good wifi at all locations. And the one that misses the most is next to the one that syncs.

Any troubleshooting advice would be great. I have a few extra nodes available so I might try that.

Am I running too many nodes?

I also read somewhere that the sync could be split into 2 different syncs or branches or something, but I don’t remember where, or know how to. I do want them all to sync the same. Would this setup help? Please point me in the right direction.

Thanks. Mike.

UDP broadcast sync is unfortunately a bit unreliable at times. You can enable Send notifications twice in Sync settings, which should cut the chance a sync is missed in half.

We will switch to using AsyncUDP for the sync functionality soon, hopefully that will improve reliability a bit.

Thank you for the quick reply! Now I know what that setting is. :slight_smile: will try that! Thanks

So I must be loosing it. I can’t find that send twice. Is it possibly not in the beta?

In your second image, the second-to-last line!

Omg. Thank you!

Happy to help, although it’s Aircookie you should be thanking! :sweat_smile: Let us know if it makes your sync more reliable!

Ha! Yes. I will. How much delay is there in sending the 2nd sync? Thought I saw on hiccup, but not sure.

It has greatly helped but not completely eliminated the skipping nodes. But much better.

It is your WiFi to blame. Bad coverage or congestion or interference can cause dropped packets.
UDP (used for sync) does no delivery checks, so dropped packet is lost forever.

The second sync immediately follows the first.